Website lacking full intag support

I am trying to find a food tracking website that works with voice computer, but the few that have the features I need don’t have full voice computer support


Are there any tips or workarounds that I can use to get it to work with a few links that lack support?

This is one website I would like to use if I could https://cronometer.com/#foods
You could try Firefox.

Intags tend to double number controls in Firefox because of the way Firefox is programmed. But, this extra numbering can be a good thing, because sometimes more controls are numbered.

Firefox and Dragon only work well together if you are using ESR versions. The ESR versions "Extended Service Release" are the only ones that support Dragon completely.

You can click on any link with our Voice Mouse feature. (Say, Show Voice Mouse). This takes a while to master but the mouse feature is very powerful and will give you complete hands-free control.






I enabled the mouse grid feature and restarted voice computer and Dragon but the command that is supposed to bring up the grid doesn’t work for me

nevermind, it suddenly started working

Great! I was in the middle of writing a reply to help you troubleshoot…

Try out the “Press x at y” command. It clicks on your specified location and then reopens the screen grid, letting you drill down through any screen.


The screen grid can be configured for your monitor so that your commands are precise.
(“Show Voice Mouse”, “Show Section Two”, and then “Show Section Alpha”)




Is there any way to make voicecomputer only click numbers when I say “click”?

Have you tried that website with Internet Explorer? VoiceComputer intags won't double there.
Appears to work fine on my computer.

By "only click numbers when I say click" you mean clicking the intags? If so, that can easily be done by editing the displaynumbers.xml in:

C:ProgramDataVoiceTeachVoiceComputerCommandsCustom

Before performing the following operations make a backup of displaynumbers.xml to a safe place!

Open displaynumbers.xml with Notepad.

Locate the: section of the XML page and then locate the following part of the script:

]]>


Change it into this:


<![CDATA[click <1to300cf>]]>

Close and save the file.

Restart VoiceComputer.

Now the numbers will only respond when preceded by "click".
<edited><editID>Speech1965</editID><editDate>2018-08-31 17:25:18</editDate></edited>

Hi, I am not sure I did this right, it is hard to navigate the code. I searched for 1to300cf in notepad and there was only one code block like the first one listed. All of the others had a second word in them like the second block. I added “click” to it to make it like the second code block, but when I save the file and restart voicecomputer, it errors with this error message " could not load C:ProgramDataVoiceTeachVoiceComputerCommandsCustomdisplaynumbers.xml"
Earthvoice2018-11-04 19:38:48

This is probably the result of a tiny error like accidentally deleting or somewhere.


Could you post the section you edited, or preferably the entire displaynumbers XML? Then I can check it out for you.

I had trouble attaching it via the forum tool so I used pastebin instead.


https://pastebin.com/mHQesPLh
The section:

]]>

appeared twice in the XML and that probably was the culprit.
Also removed some unnecessary spacing in one of the comments sections.
Tested it and now it works properly. Here it is (couldn't attach it to this message):

http://www.speechproductivity.eu/VC/displaynumbers.xml

Let me know when you've downloaded it, so I can take it off-line.


Speech19652018-11-05 14:40:39

I tried replacing the file and I get the same error

Check the

C:ProgramDataVoiceTeachVoiceComputerCommandsCustom

directory.

Make sure that you don’t have a second displaynumbers.xml file in the directory.

(Can’t have a displaynumbers - copy.xml or any other displaynumbes file.)

If this doesn’t work, reboot or just close any

C:ProgramDataVoiceTeach* directories and then run

ConfigVC.exe in the C:Program Files (x86)VoiceTeachVoiceComputerscripts

directory and then copy the new displaynumbers.xml over the old one in the
C:ProgramDataVoiceTeachVoiceComputerCommandsCustom

Open VoiceComputer and let us know!