VoiceComputer Fails to Launch Dragon 13

Hi,

I have VoiceComputer 13.05 installed and Dragon Pro 13. Unless I run Dragon first, when I run VoiceComputer the following message is displayed.


This message appears immediately after the natspeak.exe process appears in Task Manager, and the process disappears when you click 'OK' to close the message.
A VoiceComputer Utility message window is displayed showing "Opening Dragon NaturallySpeaking".

If you close the message above, a separate VoiceComputer message pops up stating "Exiting. Dragon isn't open. Please open Dragon before The VoiceComputer."

If you don't close the message above, the VoiceComputer Utility message window soon changes to "Opening VoiceComputer program". After a while the VoiceComputer Guide 'Welcome' page is displayed. However VoiceComputer is not running (no icon shown in systray).

I found that VoiceComputer can be configured for Dragon v13 (originally it was configured for Dragon v10 which I guess must be the default for the VoiceComputer installation which I find surprising).

Incidentally, the same message is displayed if you close Dragon before closing VoiceComputer.

We've now seen the same behaviour on the only other machine on which we've installed Dragon 13 and VoiceComputer 13.05, which is a client's computer.

Both machines are running Windows 7 64-bit.

On the client's machine, if you close the VoiceComputer Help window, then try to select Close VoiceComputer from the systray icon's context menu, an error message is displayed. I tried selecting another item on the menu and got the same message. I believe the message was the one below (I failed to make any notes connecting it to the behaviour described, but captured this on the same visit and believe it's the one associated with the behaviour described here).

Thanks for any suggestions,
Roger


I should’ve added that changing the VoiceComputer configuration from Dragon 10 to 13 made no difference.

Roger,

First, your problem is that Dragon is not properly installed. That is, there is a problem with your registry entries and/or Dragon program files. When that happens, VoiceComputer cannot find DNS 13 and it defaults to DNS 10.

Second, one system at a time try running a Repair of Dragon. If you are prompted when trying to run a repair from the Windows Control Panel | Programs and Features | Dragon NaturallySpeaking 13.0 | Change (top of the Programs and Features dialog) and you are prompted to insert the DVD, this means that Dragon is not properly installed. The question here is did you download Dragon Pro or did you purchase the full box product? If you downloaded DNS 13 Professional, then you have to run the setup from the download location. There is a better way to handle this, and I would be happy to explain it to you if you need such. Nevertheless, if you can’t do a repair from the Windows Control Panel | Programs and Features | Dragon NaturallySpeaking 13, then you do have a problem with your install.

Third, Close VoiceComputer from the systray icon does not shutdown VoiceComputer. It only closes the help screen (i.e., show main menu or VoiceComputer help dialog screen).

Lastly, you may have a problem with your Windows.net framework on your system. That is, you may not have the required .net framework installed, or it is not installed fully or correctly.

Try running a repair of Dragon first and let me know if that solves your problem. If not, we’ll take it to the next level.

Bottom line is that if Dragon is installed properly, VoiceComputer will find Dragon and properly enable the correct version. Also, if you’re using Windows 7 64-bit, have you installed the VoiceComputer 64-bit version?Chucker2014-11-14 12:52:20