VoiceComputer could not complete mouse action

In the past few days, I have been getting the message "VoiceComputer could not complete mouse action" about half the time when I say the number of an intag. It happens in multiple programs. I first did a repair on voice computer, then reinstalled it. I had installed iTunes and (inadvertently) Skype for business in the last few days, but I have now disabled them in the startup menu, which didn't change anything either.

Any thoughts?

Matt,

First, what is your current version of VoiceComputer. You can find this out by saying "show VoiceComputer version". It should display 2.20. If you want the exact version number, go to the Windows Control Panel | Programs and Features | VoiceComputer 2017 and locate the version number at the bottom of the screen. Let us know exactly what complete VoiceComputer version is from that location.

Second, from time to time and under certain conditions the InTag numbers may not completely refresh or refresh incorrectly. Don't try to, under this condition, say the numbers again. Instead, say either "toggle", "InTag window", or "refresh numbers". Then try accessing the number by voice command again. Let us know if the problem repeats itself after having done that.

Third, if the above doesn't resolve the problem, try doing a cold boot (shutdown VoiceComputer and Dragon, close all applications, and power off your system completely and then power back on).

Lastly, make sure that you have no pending Windows 10 updates. Pending updates that are not installed may cause either Dragon or VoiceComputer to not function properly. The problem here is mainly Dragon. In addition, it is always a good idea after installing, or reinstalling, any application, but particularly Dragon and VoiceComputer, to reboot your system using a cold boot.

Let us know if any of the above resolves the problem. Note also, that you will see this occur from time to time, but it is extremely rare. Also, let us know what applications this is occurring in. We need all this information in order to try and duplicate your problem.

Hi Chuck,


It turns out I have 2.15. How do I update?

Matt

Matt,

Send an email to Ron at info@voiceteach.com requesting such.

He may respond to you on the forum if he sees this, but I will let him know anyway.

Matt,


I sent you the link to the download of version 2.20.4.

We will have several more updates in the next few weeks.

The link that you received with your order, and that I re-sent, will always lead to the most recent download of VC 2017.



Matt,

Could it be that some other application is stealing focus from the window you are using Intags in?
Maybe you could, by way of testing, click in the window first before you issue the show numbers command.
See if that works.

Rob

Speech19652017-10-13 09:11:49
Ron,

Back channel you suggested I start a new voice file, which seems to have solved the problem. I recall that this happened before – about six months ago. And this was the same solution. (Clicking that window first didn't make a difference.)

I'm wondering if there's a way to solve this in the future without having to start over with a new voice file. Regardless, I'm glad the problem is fixed.

By the way – how do we hear about new versions of VoiceComputer being released?

– Matt

a new voice file, which seems to have solved the problem. I recall that this happened before


Yes, creating a new Dragon User Profile solves 90% of problems of what seem to be VoiceComputer problems.

>I’m wondering if there’s a way to solve this in the future without having to start over with
> a new voice file.

We’ll keep looking at this but I don’t think so. User profiles get corrupted. Sometimes it’s because you close your computer without first closing Dragon but often there’s no (known) rhyme or reason to it.

It’s been well over a year since I’ve had a corrupted user profile but occasionally I’ve had a couple of corrupted user profiles within a week or two.

> By the way – how do we hear about new versions of VoiceComputer being released?

We are continuously improving the product and have frequent, minor updates. We don’t announce most of the updates because it’s not necessary to get every update. But, the link you received with your order will always lead to the most recent release. We suggest that you upgrade every 3-6 months.
We announce major and some minor updates on this user forum.
We send emails about our major updates.

We are currently working on VC 2018 which we hope will be released by the end of the month.

The current release is VC 2017, v 2.20.5. We suggest that you upgrade to the newest release if you have any version prior to v.2.20.



Matt et al.,

The first thing to remember is that it doesn't matter what third-party application using, Dragon controls command execution.

The second thing to remember is that your user profile determines how well Dragon responds to dictation and commands. Profile corruption can be subtle or it can be catastrophic. In most cases profile corruption occurs very subtly to the extent that you may never know until situations such as yours arise.

Lastly, on a properly configured system making sure that Dragon is not copying information to its user profiles and folders while you are shutting down Dragon will prevent profile corruption. There may be times when such occurs, which can cause subtle corruption. However, this is, in my experience over the years, extremely rare. My current user profile with DPI 15 is the same one that I created when DPI 15 was released and I've never experienced any profile corruption that would interfere with VoiceComputer's InTags, or any other Dragon function. My profile was created on September 1, 2016. Still going strong.

In some cases I have run into some minor issues, such as the VoiceComputer transfer command "open notepad left" fails to execute. However, when that occurs, or similar issues like that occur, I know it's time to power off my system and power it back on (cold boot), which generally fixes the problem. Also, one of the other reasons why a user profile may become corrupted is failure to properly set the Administrative Settings for Dragon.
Chucker2017-07-10 08:21:53

Hi Chuck,


It appears my user profile became corrupted again. So I have created yet another new one. I have since made sure to “disable automatic acoustic model selection…”.

A couple of questions:

1. You mention a “properly configured system”: do you have some guidance on proper configuration?

2. What do I need to enable in VC to be able to use the “open notepad left” command? That one has never worked for me.

3. With both of my new user profiles, I haven’t been able to import my vocabulary. The text in the window in which I would do that “goes off the page,” so to speak, so I can’t get access to the button that would take me to the next window to select the vocabulary. There appears to be no way to resize the window. The fonts on my computer are set to the default, and changing them doesn’t change anything in Dragon. Do you have any thoughts about this?

Matt

Hey guys,


Aargh – it happened again. Is there any way to find out if something in my system is corrupting my voice files?

I’m wondering if it’s the program Zotero. It’s the only thing I’ve installed since the last corruption, and I installed it after the previous one with some other programs. Also, I’ve noticed that it’s interface seems to behave oddly with Dragon NaturallySpeaking and Voice Computer. For some reason, it’s drop-down menus get tiny when interacting with Dragon NaturallySpeaking and Voice Computer. Have you ever heard of anything like that?

Matt,

At this particular point you have to be more specific about "profile corruption". In other words, what do you mean specifically by "profile corruption" and what specifically is happening (i.e., step-by-step) that causes you to think that your profile has become corrupted.

The reason that you have to be more specific is that I have DPI 15 installed on three systems and have never experienced any profile corruption. Those user profiles have been there and I have not had to create new profiles since those profiles were originally created on September 1, 2016. Therefore, profile corruption is the exception, rather than the rule in most cases. Therefore, you need to be more specific.

Keep in mind that application user interfaces for any application that you have installed are, or can be, negatively impacted by your video display resolution. Since you using Windows 10 64-bit, go to the Windows 10 Settings and take a look at your display settings letting us know what they are.

Lastly, keep in mind that there are specific criteria for support of applications using Dragon, regardless of version. You can't just assume that an application will be SAPI compliant, which is required by Dragon.

Hi Chuck,

I call it "profile corruption" because that's what you and Ron suggested – see earlier in the thread. Also, some of the discussion happened back channel with Ron.

Here's what happens (four times so far):
-When I say the number of an intag, nothing happens and I get a message in the bottom right corner that says, "VoiceComputer could not complete mouse action."
-This happens about 80% of the time regardless of the program I'm working in.
-The only solution seems to be creating a new voice profile. Cold booting, restarting programs, etc., don't make a difference.

My display resolution setting is 1920x1080, the recommended resolution.

I'm not sure what SAPI compliant means, but I'm aware Dragon doesn't work with everything. But because I need to use my computer almost 100% hands-free due to a disability, I try it with everything.

Matt

I've created a new voice file, so it's not happening right now. But when and if it starts again, I'll let you know right away.

I'm not using overlays at this time. But I was planning on learning how to use them. Would this make a difference?

Thanks!

– Matt

Matt,

Couple of comments regarding Ron's post.

1. When you're getting the error that you have been previously getting with regard to executing InTags, the likelihood is that you will have the same problem with My InTags (overlays). Keep in mind that you issue a command associated with VoiceComputer, the command is not executed by VoiceComputer, it's executed by Dragon. So, if there's a problem with Dragon it will occur in any VoiceComputer commands associated with such.

2. Persistent profile corruption is extremely rare. In your case, my suspicion is that it is not your profile per se. It's likely command execution Re: Dragon. If it continues to occur persistently, I would suspect that you may have a problem with the Dragon program files. Therefore, the first thing I would suggest you do is run a repair of DPI 15. If that doesn't solve the problem, export your current user profile to a safe location, properly uninstall DPI 15 and run the DPG_DPI_15_Cleaner.exe, then reinstall DPI 15 and see if that solves the problem.

3. One thing you can try before going to the other options above is to try saying "mouse over ##" where ##is the number that you're trying to execute. That command moves the mouse pointer to the number spoken. If that works, but saying the number doesn't execute it, then the problem goes a little bit deeper than simply a corrupted user profile.

4. Also, always try saying "InTag window", "refresh numbers" or "toggle" (i.e., all VoiceComputer InTag commands) before assuming that the error is persistent. There are times where InTag numbers can be slightly off, which will result in that message. It will occur from time to time, though extremely rarely. Every now and then I see it occurring, but it is not persistent for me. Using the above commands usually refreshes the InTag numbers and aligns them properly, after which saying a particular number works properly.
Lastly, the bottom line is that persistent user profile corruption is the extreme exception. That is, once in a blue moon, 0K. Once a week or once every few days indicates something else is wrong.
Addendum:
One thing that we haven't suggested up to this point is to run a repair of VoiceComputer. If Dragon is the problem that's one thing, but it could also be VoiceComputer itself needing to be repaired. If the VoiceComputer program files are not working properly, then attributing any problems you're having with InTags to a corrupted user profile is a non sequitur.
<edited><editID>Chucker</editID><editDate>2017-07-19 16:06:06</editDate></edited>

Matt,

I've had a chance to look at your Dragon logs and your VoiceComputer log.

There doesn't seem to be anything in your Dragon logs that would indicate a corrupted user profile. Yes, there is some throttling and a couple of RPC errors (i.e., unavailable), but in general there are no significant errors that would cause me to think that your user profile has become corrupted. Therefore, continuing to create a new user profile isn't going to solve the problem simply because it's unnecessary.

On the other hand, your VoiceComputer log file shows numerous errors, particularly "bad mouse command…" which occurs far too often to be simply a quick glitch that can happen to anyone, but extremely rarely, when using VoiceComputer.

In my discussions with Ron on this issue, he is going to send you a more comprehensive (verbose) VoiceComputer 2017 that does more comprehensive error check.

In the meantime, try running a Repair of VoiceComputer and let us know whether or not that fixes the problem. Otherwise, I suspect that were getting some interference with something you're running on your system.