Voice Shortcuts failing

Hello. Just recently, Voice Shortcuts have been intermittently moving emails in Outlook to the wrong folder. For example, when I say, “Send to Client 1 folder,” Voice Shortcuts will deploy as expected but then move the email to the a folder other than the “Client 1 folder.” Any ideas? Thank you. Russell

Russell,
I guess there are several reasons why these commands could fail:

  1. Are the folder names unique, and importantly, are the first few characters of the folder names unique?
    That is, the commands will fail if your folders are named client1, client2… so you should name them 1client, 2client. - I think this is described in the voice shortcuts lesson.
  2. View recognition history to confirm that Dragon correctly understood your command.
  3. I made these commands slow to execute so that they’d be reliable on a whole range of computers but if you’re on a network, the network could hang for a while causing the commands to fail.
  4. If you didn’t include all the folders in the command, including the top level folder, the command would work when the folders are open but fail when a folder was closed.

If you email me the settings.ini file in your
C:\Users{your user name}\AppData\Roaming\VoiceTeach\VoiceComputer
folder, I may be able to identify the issue.

Hi Ron –

Thank you for your prompt reply.

  1. Nope

  2. Yes

  3. Not applicable

  4. Not applicable

Here’s specifically what’s been happening:

I have a folder called “Other.” The command is “Send to Other folder.” That worked flawlessly for years. It usually works now. Some times, however, just in the past few months, this command will send the emails to the RSS Feeds folder.

I have a folder called “Drafts.” (Yes, this is the Drafts folder that’s baked into Outlook.) The command is “Send to Drafts folder.” That worked flawlessly for years. It usually works now. Some times, however, just in the past few months, this command will send the emails to the Sent Items folder.

I will send you the settings.ini file.

Recently, I’ve been getting some "Her"s - that’s entirely new to me. I’m wondering if my microphone is failing or degrading and - right when these commands deploy - some background noise triggers the microphone, which inadvertently sends the email to the wrong folder.

The last time this happened, I think I saw the Voice Shortcut reach the “Other folder” and then suddenly jump to the RSS Feeds folder.

Thank you.

I think that this is the problem.
[Interestingly, I haven’t seen "Her"s before but it’s common to get "Him"s when your microphone degrades (usually caused by rolling over the microphone cable with a chair). ]

Looking at your settings.ini file:
The folder names in your macros are too long, which could cause random results.
The “Show Voice Shortcuts Lesson” recommends the following:
Make the first few characters of each folder unique to make the command execution faster and more reliable.
If the first few letters of your folders are unique, you just need to include the first few letters of each folder, parent, grandparent folder names to the command names.

Ron –

I think you’re exactly right – the "Her"s have been happening for me when the microphone cable slides against the rear of my desk. I can resolve that.

I’ve been a VC user since 2010 and it continues to be an awesome product.

Thank you.

Russell