vc microphone not starting?

When I tried to open “Optimise Microphone” it says that there is no log file available and “is VC microphone turned on?”.

1. How do I know if the VC microphone is on?

2. I thought that the microphone was automatically opened when voice computer was started. I have a shortcut to VC computer in the auto start menu and it definitely starts when I reboot the PC. But clearly, the microphone part is not opening.

3. This means that the microphone icon stays red and that “activate microphone” has no effect even if I repeated at 3 to 4 second intervals to reduce the level at which it should be activated. However once I have manually clicked on the red icon I get what I presume is the Dragon microphone that I can then send to sleep and wake up as usual.

okay – I’ve fiddled around a bit and got the VC microphone to start-up and the command “activate microphone” now works just fine.


However I would still be interested to know a) how I can tell if the VC microphone is on and b) how I can ensure that it starts up when I start the main VC app.

> a) how I can tell if the VC microphone is on

When the Microphone is on, there's a microphone icon on the system tray.
(It might be hidden, so you might have to select the up arrow (Show hidden icons) and move the icon to the tray.)
and b) how I can ensure that it starts up when I start the main VC app.
When the microphone is on, it stays on. Use the 'Activate VoiceComputer' command to open/close VoiceComputer/Dragon.



thanks for that. I found the microphone icon and I’ve dragged it into the system tray. It is interesting that I have the microphone set to restart every 30 minutes which I need for my quadriplegic friend and this actually adds a new microphone icon each time it restarts! If I hover the mouse over the multiple microphone icons they all disappear except the latest one. Go figure

I place both the shortcuts to voice microphone and Dragon in my startup directory


Run the command: shell:startup
to get to that folder

That way I am able to start everything completely hands-free, I can either simply say “open VoiceComputer” or “activate VoiceComputer”

I place both the shortcuts to voice microphone and Dragon in my startup directory


Enabling the VC Microphone to open on startup schedules a task that opens on startup. The task can be configured to restarted intervals so that if it stops responding it will automatically restart.

arjay,

Multiple VC microphone icons in the taskbar is a function of the way Windows work and has nothing to do with VoiceComputer. Every application, including the operating system, has its set of unique quirks.

Sure - I realise that. Just interesting is all. Plus the fact that it doesn’t help with hands-free voice control when the tray expands with a dozen duplicate icons to cover everything around it. Of course if you have manual mouse control, you can just hover over the icons and they disappear - except for the current one. But without using the mouse it just makes things in that area rather congested!


Least of my worries at the moment

By the Way - not sure why I keep getting this error message. Had it after quite a few of my posts in the last couple of days. This is my first post in 24 hours! Anyway - it is a false message in that the post that preceded it was actually posted, contrary to the message…Clap


<table =“errortable”="" cellspacing=“1” cellpadding=“3” align=“center” style=“width: 1119px;”>Error: Message Not Posted Spamming is not permitted!
You have exceeded the number of posts permitted in the time span.

Please try again later.
<edited><editID>arjay</editID><editDate>2019-07-24 14:20:52</editDate></edited>

arjay,

A lot of VoiceComputer users don’t realize how hands-free VoiceComputer is. They assume that you cannot do some things that you actually can.

For example, in the case of duplicate icons on the taskbar, all you have to do is use the InTag commands for one of the icon numbers and all of them will go away except for one. This functions exactly the same as swiping the taskbar with the mouse in such cases.

Every time the VC Microphone and the VoiceComputer startup/shutdown utilities run, they should run a subroutine that moves the mouse over the system tray, which gets rid of the extra icons.


It works perfectly for me for days on end. And then it doesn’t… (that is, the subroutine is blocked and doesn’t run…)



Still works (and has worked) great on my machine in every version of Voice Computer I ever installed.

I'm using a similar procedure to remove ghost tray icons in my SP products but it's just not as smooth and visually appealing as the one used in VoiceComputer Hug

Rob