Using the Chrome extension with the VC Beta


The VoiceComputer beta includes a stand-alone extension for Google Chrome which lets you control access and control Chrome by voice or keyboard!

After you install and open the VoiceComputer Beta, you can find the Chrome-0.x.xx.crx extension in your DocumentsVoiceComputerDocumentation directory.

To add the extension to Google Chrome:

Go to Chrome’s tools > extensions and drag and drop the extension.

Close and reopen Chrome after you add the extension.
The extension can be used by keyboard or through VoiceComputer.
To open the extension by keyboard, press the accent key (the key with the ~ sign). Press it a second time to open the keyboard entry. To follow a number, type in the number and then press enter.
To use it with VoiceComputer, say, Show or Display Numbers, then ‘click x’
Known issues with the beta:
1. It doesn’t work with the default Chrome screen. This was by design, we didn’t want to clutter the screen with numbers for all the top level controls because we have voice commands for the top level controls. (to view our commands, say, Show Chrome commands).
2. The numbers in the extension will show up in light yellow. If you get green numbers, you’re getting the built-in show numbers commands and not the extension’s show numbers.
3. You might have to repeat the command a couple of times (or close and reopen Chrome) to open Show numbers on first use.

Let us know if you have any questions!



< id=“plugin0” =“application/x-dgnria” width=“0” height=“0” style=": ; : 1000">< name=“tabId” value=“10”>

Ron,


I have found the file which is called VoiceComputer Chrome-0.3.13.crx and copied it to C:UsersVivAppDataLocalGoogleChromeApplication26.0.1410.43default_apps and C:UsersVivAppDataLocalGoogleChromeApplication26.0.1410.64default_apps, which are the only 2 folders containing files with the extension .crx.

When I open Chrome and then tools - extensions the Dragon extension is listed but not the VC file.

I also looked in C:UsersVivAppDataLocalGoogleChromeUser DataDefaultExtensions and there are 4 folders with long names consisting of random selections of letters but nowhere buried in any of them are any crx files.

As the extension does not work with Chrome at the moment can you advise me where I am going wrong please.

Viv

Viv,

First, open Chrome. Click on the settings button (i.e., 3 vertical bars on the far right side). It’s on the same line as the address bar. If you mouse over it, it says “Customize and control Google Chrome”.

Second, from the pop-up menu select Tools, and then select Extensions.

Lastly, you have to drag and drop VoiceComputer Chrome-0.3.13.crx into the Extensions window. You will be prompted as to whether or not you want to add it. Click on the add button and it will install the extension.

After you do all of the above, you will be able to use the Chrome extension.

If you have any other questions about how to use it with VoiceComputer, you can say “show chrome commands” for the list of commands that you can use with the extension. Otherwise, just ask.

I’m posting the complete set of instructions for anyone else who may be having the same problem.Chucker2013-05-24 19:51:20

Thanks Chuck,


I was making it a lot more complicated to install the extension than needed, but I have now done it.

The numbers show up white on a blue background, not yellow or green as was suggested. Also, it does not matter whether I press ‘Shift + #’, or just ‘#’, it does not open the display numbers overlay.

But a little bit of research has shown that you are referring to the key to the left of the number 1 key on a US keyboard, which is 3 keys to the right of the ‘L’ key on the UK keyboard. If I press the key to the left of the number 1 then I can open the display numbers using the keyboard, and the {esc} key does close the number display, and that seems to be the only one which would do this trick.

I like the fact that the overlay stays on the screen until I say ‘close numbers’, and that the numbers change when I click on a link and move to another page.

I will play more later on.

Viv

Viv,

Sorry, we didn't take into consideration the fact that some users may not be using a US keyboard.

As you have discovered, it is the accent key ( ` ) that toggles the display on and the escape key (esc) that toggles them off via the keyboard.

As far as the background colors and numbers sizes are concerned, if you say "configure VoiceComputer" you'll see an option for configuring these for "Display Numbers/Show Numbers" and Super Numbers. This is number 12 on the configure VoiceComputer options. You can set the font size, the background color and the transparency level. These tech effect immediately upon setting them, but what you're seeing is the default for the Chrome extension. However, we are still tinkering with the Chrome extension. So if this doesn't work for you, don't worry about it. We will be updating the Chrome extension shortly and will continue to do so from time to time because there are webpages with objects that we need to enable, such as the Google options when you create a new tab. Nonetheless, try it and let me know if it works for you in the version of the Chrome extension that you currently have.

I should have mentioned, but I'll mention it now, that the accent sign is usually underneath the ~ on most keyboards, if I'm not mistaken.
Chucker2013-05-25 14:25:48

Thanks Chuck,


No need to apologise, it is difficult to remember everything, (for me anyway), and at least I did find the solution.

I did configure number 12 on first opening VC to yellow display numbers background, green super numbers background, but the background in Chrome for display numbers is always blue with white numbers, which is not a problem. I see the yellow and green background in other applications, as expected.

The # sign is under the ~ sign on UK keyboards. The accent sign, `, is to the left of the 1 key and is with the ¬ and ¦ signs, although the latter needs the Ctrl and Alt keys depressed at the same time.

Viv

>but the background in Chrome for display numbers is always blue with white numbers
I just sent you an updated Chrome extension. This now displays numbers in Chrome in black with a yellow background. More significantly this right aligns the numbering, letting you click a number, enter text for the field selected and immediately click other links, without needing to reopen the display.

< id=“plugin0” =“application/x-dgnria” width=“0” height=“0” style=": ; : 1000">< name=“tabId” value=“2”>

Ron,


I have installed the new Chrome extension and had a little play.

Display numbers now gives a yellow background.

The command ‘full screen toggle’ does not seem to do anything.

The command ‘next pane’ selects the text in the address bar.

‘New<span =“Apple-tab-span” style=“white-space:pre”> tab’ either does nothing or, if the address bar has been selected, inserts the text “new tab” in it and drops down the list of the last few opened websites.

‘Open home page’ does not seem to do anything.

‘Save as bookmark’ opens the file save dialogue box as if I want to save something in the downloads folder.

I may be able to have another play tomorrow.

Viv

I just have a quick question. The extension works great in helping to control the computer while using chrome. However, should I be able to dictate into text boxes within chrome? For example, I could not dictate this message without using the dictation box on the forum website. I’m just wondering if that still is considered normal?< id=“plugin0” =“application/x-dgnria” width=“0” height=“0” style=": ; : 1000">< name=“tabId” value=“44”>

Gary,

VoiceComputer does not add anything to Dragon’s capability for dictating into Google Chrome. Unfortunately, Chrome is not Full Text Control (Select-and Say) enabled in any version of DNS. The only thing that the Google Chrome extension allows you to do is to navigate via Display Numbers. Full Text Control (Select-and Say) is entirely controlled by Dragon.

The bottom line is that you have to use the Dictation Box.

Ron,
Someone reported the same problem I had about dictation into text boxes on the nuance forum. They suggested disabling the automatic dictation box feature. I did that and what do you know…In fact, this post is being dictated using Google Chrome and without the dictation box. If that works consistently, that will be a tremendous help.
< id=“plugin0” =“application/x-dgnria” width=“0” height=“0” style=": ; : 1000">< name=“tabId” value=“48”>

Gary,

Sorry, it wasn’t clear from your post that that was what you were referring to. I think you were referring to my post on the KnowBrainer forum, but it has been referenced several times on numerous forums by myself and others.

Glad you got it straightened out.