Strange microphone issue

I have a strange issue that I need to resolve. My first install of the latest version of Voice Computer went to my Microsoft surface Pro 4 using Windows 10. I was experimenting a little with the VC microphone but decided to continue using the regular Dragon microphone. For some reason, that computer intermittently makes the mute button turn to on, in my external microphone. I physically shut it off which is just annoying but not a critical problem. However, last Thursday and again tonight I was teaching an online class that required me to use my external microphone. Intermittently I get a message that says another software program is muting your microphone. Do you want to continue yes or no? Interestingly, I have the latest version of voice computer on my other laptop where I never touched the voice computer microphone. That one worked like a top without any error message or issue. Does anyone have any idea what I can do other than uninstalling and reinstalling voice computer on the Microsoft SP4?

This is strange. If you configure the VC Mic to start when you turn on the computer and restart periodically, the VC Mic can pick up commands to turn the Dragon mic on and off.


You can get rid of the scheduling by Configuring VoiceComputer, selecting Enable / Disable VC Mic to open on startup and restart at intervals, then saying “Configure Microphone” then selecting ‘No’ on the next step. (If you’ve already created a task, select ‘No’ to delete it.
(Or you can go Task Scheduler and deleting the ‘RestartVCMic’ task. If you used this feature in an older release of VoiceComputer, also delete 'RunVCmic".

Ron,


I tried your remedy, but it didn’t help. I’m very confident it has nothing to do with voice computer. I want to share what I did in case anyone else runs into this or, has in the past.

After trying your instruction, I completely uninstalled VC and still had the same problem where the microphone mute button goes on and I get a message that says, "another program has muted your microphone, to shut the mute off, press yes or no. The only thing it has in common with VC is that I first noticed it on the day I installed the program.
So, I reinstalled VC and have been trying to eliminate every other variable since. The only big clue I have is that when I went to the Microsoft store, I could not replicate the problem there. I then went into a Starbucks, and I still could not replicate the problem. As soon as I came home, the problem started again. I’ve done the following,
changed microphones
shut all my Bluetooth devices off
shut my other laptop off
uninstalled and reinstalled the microphone drivers
shut off my Wi-Fi and started using my hotspot from my cell phone
None of that worked. In fact, while dictating this note, I got the same message. It is quite a mystery. By the way, my second laptop running Windows 8 also has voice computer and has no problem using the same microphone.

Gary,

Based on your description the problem, I would tend to agree with you that it has nothing to do with VoiceComputer.

However, it isn't necessary to wrap your leg around your neck in order to test out where the problem is coming from. In other words, it isn't necessary to uninstall/reinstall VoiceComputer. To test this type of problem, try the following next time it occurs.

1. No two systems are alike. Even the same microphone on a different system may not function exactly the same.

2. If you can keep the microphone on by turning it on manually the next time this occurs, simply say "shutdown VoiceComputer" followed by "Shutdown Speech". If the VC microphone icon is in the system tray (systray), right-click on it and ""click" close. This will shut down everything related to VoiceComputer.

3. Open Dragon by itself and test whether the problem persists (recurs). If it does, send me a copy of your Dragon.log file to chuck@voiceteach.com so that I can take a look at it and see if there's anything in there that may indicate what's going on. Also, immediately after such occurs, view the recognition history and see if Dragon is responding to something that you're saying differently than what you would expect it to do/display.

4. I gather from your post that since the problem is occurring only on your Microsoft surface Pro 4, what is causing the problem is unique to that system. A couple of other users have had similar experiences, though not on the Surface Pro 4. This can be a tough nut to crack, but perhaps we can help you follow these instructions.

Thank you. I just sent you three files.

One – Microsoft error picture
two – Dragon recognition history
three – Dragon log file

I can’t wait to see what you find. I thought I went through every possible variable.

Gary,

I’ve not found anything in any of the information that you sent me that would indicate specifically and clearly either when the microphone is going mute or what’s causing it.

Am I correct in assuming that it’s happening in Google Chrome? If so, where (i.e., URL or webpage).

Are you by any chance engaging the Google microphone and not turning it off?

Lastly, have you check the Windows Sound dialog? If so, what is the default microphone and are there any other input devices (Recording devices) that are active. I’m particularly referring to your built-in camera microphone. Try disabling any other Recording devices except the one that you’re going to use, but don’t hide them, just disable them.
Also, where did that error message come from? That is, when application window or webpage where you in when you were shown that message.
Chucker2017-02-24 17:59:43

Chucker,


Thank you for your suggestions. Unfortunately, the problem still persists even after I double checked that the Google microphone is off, and I purposely disabled anything that even sounds like a microphone. The issue happens with any application that requires a microphone. What still makes it strange, is that it only happens in my house. I pretty much uncovered all the variables. On top of everything else, I tried disconnecting it from the docking station; I took it off the Wi-Fi and put it on the hotspot and about 50 other things. I spoke to Microsoft by phone today. They said they know about the issue, and it is definitely Windows 10 problem. They said that senior support would be calling me in the next 24 hours. I’ll report back here to tell you what they tell me. Because, if it’s a Windows 10 problem, more than just me will probably experience it. In fact, the technician told me that at least 51 other people had called in with the same issue in the last few months.

Gary,

Microsoft may be correct. However, there are very few Windows 10 users who are experiencing this particular problem.

I know that I have been using Windows 10 on three different systems since day one. I have never had this particular problem rear its ugly head on any of those systems.

I would definitely be interesting and what Microsoft has to say relative to your problem. I suspect that it goes a little deeper than simply Windows 10. Consider the fact that it doesn't occur for you at Starbucks, but it rears its ugly head at home. Since you're still using the same hardware, just in different locations, the problem can't be just Windows 10. It must be Windows 10 relative to something that changes between the location where you experienced the problem and the locations where you do not.

Logic 101: Post Hoc fallacy - The logical fallacy of believing that temporal succession implies a causal relation.

I know, it’s totally bizarre and defies reason. My guess is, I’m going to find something really obvious that I overlooked… Keep in mind, that I have another laptop running Windows 8 about 6 inches from my Microsoft surface and it had absolutely no problems.

Double check the Windows task scheduler.


Look for a ‘RestartVCMic’ or a 'RunVCmic" task in the Task Scheduler Library. If you find anything, delete it.


Ron,


Thank you for your suggestions but unfortunately those settings were okay as per your instructions. The good news is that it only happens when I am at home. It’s a bit annoying there because the mute button goes on occasionally while I am in the middle of dictating. However, I have found workarounds, and I have another laptop. When I was out of town last week, I was using a very microphone intensive application and never experienced any kind of mute issue. It’s more strange than anything else that it happens only at my house. From experience, I am sure I will find the culprit. Microsoft hinted that the microphone application built into one note may be the cause.

Gary,

There is a quick way to test whether that is the case. Simply disable OneNote completely.

However, I doubt seriously that that will solve the problem itself. Nevertheless, I'm always prepared to be surprised.

I think I finally resolved the issue of why I was getting a message stating that another microphone was muting my headset. I wanted to let everyone know in case you run into the same issue.


I have a Bluetooth Plantronics earpiece that sits on its own cradle, which is connected to the back of my surface Pro4 docking station. Somehow, (probably only chucker could figure that out) by having it plugged into the docking station it acted as the mysterious microphone that was pushing my Dragon headset (fantastic Sennsheiser MB2 Bluetooth microphone) to second in line with my computer. I want to thank everyone for trying to help me figure this one out. It took three months, but I think I succeeded.

Gary,

Thank you for the update. That is an extremely useful piece of information.

Unfortunately, this is one of the problems with using a docking station (apparently). There are others, but I don't often think of asking whether or not someone is using a docking station under this condition. From now on, I will.

What causes it? It's basically the way that the docking station works in that it shifts things around. Why it does this is anybody's guess. Nevertheless, everyone should be advised that if they run into this type of problem and they're using a docking station, they should check it as you did.