My personal commands are fickle

With Chucker’s help, I was able to import my personal commands to the latest version. However, the commands only work on one side of the equation. My “open from” commands work flawlessly. My “save in” commands just come up as dictation.

Any thoughts?

Much appreciated,

Jim

Jim,

Make sure that you’re using the correct command. It’s not “save in”, it’s “save to”.

Also, it’s based on the tag commands. "Open from " and "save to when you use the tag commands to create tagged and bookmarked folders.

Chucker,

thanks for getting back to me. However, an illustrative command “save to Triona folder” merely becomes dictation.

Enjoy the rest of your weekend.

Jim

Chuck,

What is the difference between a bookmarked command and a tagged command?

If you tag a file, folder or web page, it is listed on the “Show My Favorites” list, letting you access the favorite in two commands.


If you also bookmark it, you can also open the folder… in one command, as in "Open tag " “Open tag left”

Jim,

There are certain conditions that must exist before the “save to folder” will work properly.

  1. The file that you want to save must be opened in the appropriate application.

  2. The bookmarked and tagged folder must be accessible. That is, Dragon/VoiceComputer must be able to access that folder when issuing the command. If the folder is not accessible, the command won’t work.

  3. The “save to” command must be spoken verbatim. That is, you must say “saved to Triona folder”.

  4. If the folder is inaccessible, the tagged and bookmarked folder is not being displayed in “show my favorites” or you haven’t properly enabled the appropriate VoiceComputer command options in “Enable | Disable VoiceComputer commands”, then you very likely will get the command displayed as text.

If I’m not mistaken, you must have the “Voice Shortcuts Commands” enabled (selected).

Lastly, you don’t need to have the particular application open when you elect to open a file from a bookmarked and tagged folder as long as you follow the prompts correctly. However, the file that you want to save must be open in the appropriate application in order to use the “save to…” folder command.

If you’re still having a problem with this, let me know. I just tested it by creating a folder called “Triona”, bookmarking and tagging this folder, which I created on a USB flash drive and copied several files into it, and then tested both commands. They work properly for me.Chucker2013-10-08 06:51:53

Chucker:

I went ahead and looked at my favorites list. The command was not in it. For whatever reason, it had not imported. Now everything is working perfectly.

Interestingly, I had to type in the folder name after I gave the tag and number command. However, I was able to use the command bookmark and safe. Electrons!

So it goes.

As always, thanks and much appreciated.

Jim

Jim,

all VoiceComputer dialogs our fully speech enabled [Say-What-You-See (Tracking)]. If you can’t dictate into the “Choose a phrase” text box, try saying “choose a phrase” and then tried dictating. There’s no reason why you can’t dictate into that text box in the Tag Wizard. If you can’t, then something is wrong.

Gary,

When using the Tag Wizard, in addition to what Ron has already posted, you get the best of all worlds with VoiceComputer by saying “bookmark and save”. If you read the instructions at the bottom of that dialog, it should be clear. Regardless, by tagging and bookmarking using the command “bookmark and save”, you are creating the ability to access files folders and webpages using the “show my favorites” VoiceComputer command or by using the "open tag " or “open tag <position/location>”.

You also can avail yourself of the “Save to/Open from folder” as I’ve described above for Jim and I as I have described previously in other posts.Chucker2013-10-08 13:21:16

Ron,

I just downloaded version 60. I successfully imported my personal commands. However, when I tried to save to my dictation folder with the command "save to dictation folder "it didn’t work. Nor did the command “save to tag dictation.”

The “open from dictation folder” did not work; however, the command “open tag dictation” did.

Could this be related to the government shutdown?

As always, thanks so much,

Jim

Jim,

Assuming that your “dictation” folder is tagged and bookmarked, but you should check it anyway, I have to make one correction on the use of the Open from/Save to commands from what I had previously reported.

I had previously reported that I had been able to open from a tagged/bookmarked folder from the Windows desktop. That was a fluke. I apologize for that. VoiceComputer doesn’t normally open that dialog when using the “Open from” the Windows Desktop. It was just the way that that system was set up. Under normal conditions, that will work when using this command.

In order to use these commands, you have to be in an application window. This can be DragonPad, notepad, WordPad, Microsoft Word, Corel WordPerfect, Adobe acrobat, etc., but you must be in an application window in order to use the “open from folder”.

As regards the “Save to” command you must have a file open in an application window in order to use the “Save to folder”. The file can be untitled, or in the case of Microsoft Word it can be titled “Document 1” etc. because you can always rename the file when you get to the specific folder in the “Save to… folder”.

Regardless, the commands only work under the proper conditions. Be sure that you are following the guidelines above. If you’re still having a problem, let me know.

Chucker,

as usual, much appreciated. The only command that works is the "open from. No others do. Attached is word document I just tested.

Thanks. It is the shutdown.

Jim

Here is the attachment that I could attach to my previous post.

Thanks.Testing.txt

well that attachment didn’t work. Here is what is on the document in Word:

Testing, testing, testing.

I’m testing my commands.

Save to dictation folder
save to tag dictation
open from dictation folder
save to allied world folder
save to tag dictation folder

Trionalaw2013-10-16 11:12:51

Jim,

Make sure that under the “Enable | Disable VoiceComputer Commands” that you have the “Voice Shortcut Commands” enabled.

Let me know if that was unchecked and if it changes the results after you place a checkmark in that option. Remember, after doing so you have to “Restart Speech” for it to take effect.

"Save to tag " is not a valid command in VoiceComputer.Chucker2013-10-16 12:37:26

Chucker,

it was not checked. I checked it, closedown of everything and restarted my computer by shutting it down to clear the memory. Now no commands work. Here is what’s written on the Word document:

Testing, testing, testing.

Save to dictation folder
save to my dictation folder
save to trial calendar folder
save to tag dictation
open from trial calendar folder
open from tag trial calendar
open from tag oasis
open from tag dictation
save to tag dictation approved

who was at that said “It’s the end of the world as we know it and I feel fine”?

Thanks,

Jim

Chuck,

Thank you for your note. I actually use the tag commands regularly. In fact, besides the, "save to" Outlook commands, those are the ones I use most often.

Jim,

Save to dictation folder – should work

save to my dictation folder – unless you have a folder tagged as “my dictation” won’t work. If you’re trying to do it in Outlook, you have to have an Outlook folder by that name. Also, be careful how you name your folders in Outlook. It is possible to create a folder that won’t be recognized properly even though it’s set up correctly.

save to trial calendar folder – same as above. Besides, this is basically an Outlook shortcuts command. And there needs to be a folder in Outlook labeled “trial calendar”.

save to tag dictation – should only print the text in Microsoft Word
open from trial calendar folder – unless you have a folder tagged as “trial calendar” it won’t work. Also, not an Outlook VoiceShortcut.

open from tag trial calendar – not a valid VoiceComputer command

open from tag oasis – shouldn’t work, not a valid VoiceComputer command

open from tag dictation – shouldn’t work. Should only result in text displayed in Microsoft Word.

Save to tag dictation approved – same as above

When you’re looking at the file commands, use the commands that are shown in the “show file commands” Help in VoiceComputer (i.e., Accessing Files).

Command rule #1: commands, whether Dragon or VoiceComputer, must be spoken verbatim or they won’t be understood. For example, in Microsoft Excel when you want to select a range of cells you say “select cell alpha-1 through cell Delta-7”. If you leave out the word “cell” as noted in bold red, the command may look right, but it won’t execute.Chucker2013-10-17 08:38:46

Thanks, Chucker:

I thought if you could not get a command to work with using just folder, you were to add “my” before the folder’s name. See section 5 in the accessing files help.

I do not use these commands in Outlook. Only Word.

If I am reading the instructions correctly, you can only use the tag bookmark to open files but not to save them. Is that correct?

Of course, now the commands are working. Go figure.

Much appreciated,

JimTrionalaw2013-10-17 08:36:31

Jim,

You’re getting the hang of it.

Much appreciated, chucker:


Am I correct about the tag command only opening files?

Thanks,

Jim