Multiple monitor issue

Hi,

I be grateful if somebody could advise why I am experiencing issues with placing of applications on separate monitors.


Current setup:

DPI 14
Surface Pro 3 (I5)
2X external ViewSonic 21 inch monitors (In display settings monitor 1 = surface pro screen, monitor 2 = left-hand ViewSonic monitor, monitor 3 = right hand ViewSonic monitor).
Current resolution on all devices 1920X1080
Voice computer version 2.19.2


Issue:


Example, I am working in Microsoft Excel which is being displayed on my surface pro screen, I say "place window on monitor 2", and Microsoft excel acts as if I have resized the window (by a very small amount) and then stays on the surface pro screen. If I say the same for monitor 1, it places it on monitor 2.


Also, as above and I say "place window on monitor 1", Microsoft Excel is then placed on monitor 2 (as per display settings) but is not fitted into screen and overhangs from this monitor into the surface pro screen. I then have to say "maximise window" at which point it then fits into the screen.

I have run through the Voice Computer process for additional monitors however the problem persists. It could be PICNIC, however I would be grateful of any help!


Thanks

Paul

do the

Show Screen Grid on Monitor <One | Two | Three>

commands work correctly?

If not, reconfigure

(However, the code for the Screen Grid and moving the programs are quite different.)

Let us know.




Hi,
Yes, the screen grid command works and actually places the screen grid on the correct monitor as per the screen resolution set up.
Thanks
Paul

I need to test this with my Surface Pro in a few days. But, my untested opinion:

The place window commands are programmed so that the left monitor is monitor one, (That is, when you move the mouse all the way to the left, that is monitor one.) Is this the way it's working?

>but is not fitted into screen and overhangs from this monitor into the surface pro screen.
> I then have to say "maximise window" at which point it then fits into the screen.

I don't see why this should happen. I'll check my own setup. Since this doesn't usually happen, the easiest fix for this to add a heardword maximize Window command to the "place window on monitor 2" command in the xml file.

First, I check this as soon as I can...





yes, monitor 1 is the leftmost one.

> (In display settings monitor 1 = surface pro screen, monitor 2 = left-hand
> ViewSonic monitor, monitor 3 = right hand ViewSonic monitor).

I suggest that you go to your display settings and drag monitor 2 so that it's monitor 1.

In other words, to adjust your monitor settings so that it matches our program (to the best of my knowledge, our program is just taking the Window settings as reported to it, so we can't change anything.)
After you adjust the display settings to match our program, then reconfigure our mouse settings so they are also consistent.
(Our mouse configuration are separate than and independent of our position commands.)