Mouse and super numbers issues with VC 13 and DNS

I installed DNS 13 Pro and VC 13 (latest) on Friday and I’m having trouble some commands related to mousing and show numbers.


With regard to the mouse, I can’t say “click” anymore when giving an X and Y position. (E.g. “click 50 at 50”) It only accepts “left.” Oddly, I cannot say “right” and the X and Y position; it only accepts “right-click” and the X and Y position.

Also, some instances of mouse clicking are resulting in the microphone being toggled off. Here are some instances I have noticed so far:
<p =“MsoListBulletCxSpFirst”> ·
“Double-click 5 at 15” resulted in
appropriate action, but also turning off microphone<o:p></o:p>
<p ="MsoListBulletCxSpMiddle"><!--if !supLists--><span style="font-family:Symbol;mso-fareast-font-family:Symbol;mso-bidi-font-family:  Symbol">·<span style="font-stretch: normal; font-size: 7pt; line-height: normal; font-family: 'Times New Roman';">
</span></span><!---->similar thing happened with "double-click
18" using "show numbers" in Windows Explorer (the action opened
up a Word document as expected, but also turned off the microphone)<o:p></o:p></p>

<p ="MsoListBulletCxSpLast"><!--if !supLists--><span style="font-family:Symbol;mso-fareast-font-family:Symbol;mso-bidi-font-family:  Symbol">·<span style="font-stretch: normal; font-size: 7pt; line-height: normal; font-family: 'Times New Roman';">
</span></span><!---->similar thing happened with the right-click
action using show numbers in Windows Explorer<o:p></o:p></p></div>

Mike,

Check your VoiceComputer configuration (i.e., say configure VoiceComputer) or right-click it from the VoiceComputer icon in the systray. Go to 5 (Configure VoiceComputer for your version of Dragon) and make sure that it is properly configured for Dragon NaturallySpeaking 13.

If it is properly configured, let me know. If not, then click the radio button for Dragon NaturallySpeaking 13, close Dragon and VoiceComputer using the VoiceComputer Control Center “Restart Speech” and try again.

Also, make sure that you have properly set the desired options in the Enable | Disable VoiceComputer commands.Chucker2014-10-20 13:58:45

Hi Chuck,


It is already configured for DNS 13.

These are the VC commands I have enabled:
– Global Commands, 1 & 2
– VoiceComputer’s help and training
– desktop control commands
– show file and folder commands
– Windows 8 commands
– Mouse commands
– Super number commands
– Show my number commands
– Gmail or Google Chrome commands
– Adobe Reader commands
– Adobe Acrobat commands
– snag it commands
– act, Quicken, etc.
– Thunderbird, etc.
– WordPerfect, etc.
– Windows Explorer Commands

FYI, running Windows 8.1.

Mike,

First, is there a reason why you haven’t enabled the Microsoft Office commands (I.E., MS Word Commands, MS Excel Commands, MS PowerPoint Commands, MS Outlook Commands)? I would assume that you would unselect these because you’re not using Microsoft Office, but you know the old saying about assumptions. Please let me know.

Second, if you’re using Adobe Acrobat, which are you using Reader or the full version of Adobe Acrobat (i.e., Pro or Standard)? If you’re using Acrobat Reader, then unselect the commands for Adobe Acrobat. If you using Adobe Acrobat Reader, then unselect the commands for Adobe Acrobat. You only need the set of commands for the version of Adobe Acrobat that you’re using. You can save on resources by disabling one of the other.

Third, the SnagIt commands only work for up to SnagIt 11.03. If you’re using a version of SnagIt any later than that, these commands are not applicable and won’t work properly. That being said, I would assume that you’re not using SnagIt. If so, disable those commands. Also, disable them if you’re using SnagIt 11.04-12.2.1, these commands are not applicable to those versions. Again, you can save on resources by disabling commands for any application that you’re not using. The same applies to the commands for WordPerfect, Thunderbird, and Gmail or Google Chrome commands.

Fourth, I’ve tested the VoiceComputer Mouse commands that you highlight in your post and I’ve tested them under Windows 7 64-bit and Windows 8.1 64-bit. I’ve also tested them under Windows 7 32-bit. They are all working properly for me. Therefore, I have a couple of suggestions and tips.

  1. Sometimes having Dragon’s Options | Commands tab | Enable mouse motion commands enabled when you’re using VoiceComputer can interfere with VoiceComputer’s Mouse commands. I’ve never found this to be true in my case on any one of my four systems, but it’s possible. If you want to use VoiceComputer’s Mouse commands, remove the checkmark from Enable mouse motion commands. This takes effect immediately and if you need them, you can always go back and reenable that option.

  2. As with any commands (i.e., Dragon, KnowBrainer, VoiceComputer, etc. ad infinitum), commands must be spoken continuously without pausing between words in such. Pauses when issuing commands will cause commands to tend to fail or execute incorrectly.

  3. If you have the Results box (Dragon) displaying when you issue any of your noted Mouse commands, are the commands recognized correctly in the Results Box? This is one way to test whether or not the commands are being recognized correctly. The other way is to “view recognition history” in Dragon after you issue a VoiceComputer Mouse command that doesn’t work properly. Is the command properly recognized in the Recognition history?

  4. When using Windows 8.1, are you attempting to issue VoiceComputer Mouse commands in the Windows 8.1 Menu (i.e., formerly known as Metro). This can sometimes be problematic even for DNS 13. One of the ways that I ensure that Windows 8.1 is fully Dragon compatible is to use a Start menu program, such as Start8 from Stardock software:

http://www.stardock.com/products/

This gives you back the classic Windows Start menu and always resorts to the Windows 8.1 desktop vs. the Windows 8.1 menu (Metro).

  1. There are times, rare though they may be, where the microphone that you’re using may not pick up your commands or dictation accurately. When you have trouble with any commands, always rerun the Audio Setup Wizard and restart VoiceComputer and Dragon Using the VoiceComputer Control Center. Also, it is possible, though again rare, launching VoiceComputer after configuring such doesn’t properly load the selected commands. In this case, if you go back to the “Configure VoiceComputer” dialog | Enable | Disable VoiceComputer Commands and simply click on the OK button, followed by restarting VoiceComputer (Restart Speech), VoiceComputer will reconfigure your commands (i.e., you will see the small dialog that indicates such on restarting VoiceComputer).

Let me know if I’ve missed anything and/or if you’re still having problems with the Mouse commands.Chucker2014-10-21 12:19:03

Hi Chuck,

Thank you for your thorough reply. Thank you for the tips about non-mouse -related commands. Helpful advice. As for MS office, I've got a lot of my own commands built up over the years, and am reluctant to enable additional command sets until I take the time to understand them (which I haven't done yet with VC).

As for the mousing, none of this is occurring in Metro. I use the classic Windows desktop in 8.1 64 bi and am running my programs in it. Also, it's the same system on which I wasn't having these mousing problems on Thursday, before I upgraded. (Previously running Dragon 12.5 Pro and a relatively recent version of VC 12 point whatever.)

I opened up the VC configuration menu, unchecked and checked again the relevant boxes, then restarted VC. No change. Also disabled DNS mouse motion commands (which I like), and still no change.

Still intermittently experiencing the issue with microphone toggling off. Also I cannot say "click" or "right" before my X at Y commands. Such phrases are not recognized as commands, but rather appear to be recognized as dictation. I will demonstrate: "click 70 at 37" was what I just spoke, absent the quotation marks, in a single utterance. Came out as you see it in DragonPad. If I'm somewhere without full Select-and-Say capability, it appears there is no recognition, with the View Recognition History showing <???>.

I should note that I am able to say the word "click" when using "show numbers" – I just tested it. Normally I just say the number.

Further advice would be welcome.

Thanks,

Mike

Mike,

I personally don’t use the Dragon mouse motion commands because they’re too slow. However, if you find them useful, you can turn them back on. I just wanted to make sure that you tested without them and were still having the same problem.

I’ll take a look at the VoiceComputer Mouse commands in Windows 8.1 on my Lenovo Multitouch Twist and see if I can duplicate your problem. However, all of the VoiceComputer Mouse commands work fine for me. In addition, they should even work application text Windows that don’t support Full Text Control (Select-and-Say). VoiceComputer commands are not part of Dragon’s Natural Language Commands, which don’t work in text Windows that do not support Full Text Control (Select-and-Say), but this does not affect VoiceComputer’s commands and functionality.

Do keep in mind that in Windows Explorer (i.e., File Explorer in Windows 8.1) should allow you accessibility to numbers by simply saying the number, but to open a file or folder is a mouse double-click operation, so you would have to say “double-click #” where #= the number of the file or folder that you want to open. Simply saying the number only highlights that file or folder. The same applies to any similar type of application. You can also use “control click” and “shift click” to select items in a list, such as emails in Microsoft Outlook. Although, there are other controls for Show Numbers in Outlook that allow you to use these commands with the numbers, such as “control click 69” or “shift click 45”, which are just examples of numbered items (emails in your inbox).

Hi Chuck,

<p ="Msonormal"><span style="color: rgb34, 42, 53; font-family: Calibri, sans-serif; line-height: 1.4;">Thanks
for your response. I don't generally say "click" when using Show
Numbers – was just testing it to see if it was something about the word
"click."</span></p>

<p ="Msonormal"><span style="color: rgb34, 42, 53; font-family: Calibri, sans-serif; line-height: 1.4;">Any
additional ideas on why "click" and "right" prefaces with
the X at Y commands might not be working?</span></p>

<p ="Msonormal"><span style="color: rgb34, 42, 53; font-family: Calibri, sans-serif; line-height: 1.4;">As
for the intermittent toggling off of the microphone when I say
"double-click" or "right-click" with Show Numbers, I have a
suspicion it's related to the VC microphone. Yesterday, I closed it, and stopped
having the intermittent issues. Today, it's back on, and the issues have arisen
again. I'd rather not have to keep the VC microphone closed, as I like it, but
maybe that's what I will need to do.</span></p><p ="Msonormal"><span style="line-height: 1.4; font-family: Calibri, sans-serif; color: rgb34, 42, 53;">Any additional ideas?</span><span style="line-height: 1.4; color: rgb34, 42, 53; font-family: Calibri, sans-serif;"> </span></p>

<p ="Msonormal"><span style="font-family:"Calibri","sans-serif";color:#222A35">Mike<o:p></o:p></span></p>