Maximize window command

Sometimes when I say “maximize window” the active window does not maximize. It looks as if it tries to execute the command but is unable to do so for some reason. So far I have been unable to figure out when this will happen. A workaround that I discovered is to first issue a “move window…” command. After the window moves, it will then maximize properly. I think this may have happened to me when I wanted to minimize a window a time or two, but I can’t be certain.

Has anyone else had this happen to them?

This always happens to me after using any of the "place program " commands, e.g., “place program left,” which I use quite a bit. If I then want to maximize the window, I use “restore window”, followed by “maximize window.” (Actually I more often use the KnowBrainer “Restore” and “Maximize” commands, since they’re a bit shorter to say.)


Fred

rj,

I don't seem to be able to duplicate your problem. As long as any particular window that I have open has focus, if I say "maximize window", the window gets maximized. However, keep in mind that this is a Dragon command, not a VoicePower command.

We try not to duplicate commands that are already available via Dragon.

Fred is spot on. This behavior only happens when I have used a “place window” command on the active window. The only way to get the window to maximize is to issue some other command first such as “minimize window”, “make window bigger”, “move window left” etc. I’m really glad he chimed in, because now I know I’m not the only one with this problem.

rj,

Again, I can't duplicate your problem. I open windows, place windows, move them around, make them bigger, make them narrower, make them wider, etc. yada yada yada. Regardless, I can still maximize any window that has focus regardless of the commands I use or how I open that particular application and/or document.

Have either you or Fred tried the "place focus " command and then tried maximizing. Because maximize window is a Dragon command, the only reason that I can think of is that even though it may be the active window it may not have focus (i.e., I know that the active window is, or should be, the window in focus, but that still could be the issue).

Couple of quick questions: (1) can you click on the maximize button and doesn't maximize the window?, and (2) can you use the maximize window command if you click on the title bar for the active window?

Just out of curiosity, what version of VoicePower are we talking about? Just say "show VoicePower version" and let me know.

Chucker2012-05-31 07:56:30

Chuck,

In my case, I cannot click on the maximize button because, as it turns out, there is no maximize button (for me anyway) after using the "place window " command. There is just a minimize button and a restore button, unchanged from the way they look in a maximized window. Thus, if I click on the title bar as you suggest, it does not enable use of the maximize window command. However, if I double-click on the title bar, I noticed that the window resizes itself ever so slightly and the maximize button appears, replacing the restore button. In this case the maximize window command works.
It is not really a problem for me and I mention it only because rj asked about it. I am using VP version 11.7.1.1.
Fred

Fred F2012-06-01 23:03:10

The application windows are, for example, Internet Explorer 9, Word 2010 and Excel 2010.

To be more precise about what I mentioned in my previous post, I do see three buttons in the upper right-hand corner of a full-size window: close, “restore down” and minimize. After using “place window left,” for example, the window is resized and repositioned, and those three buttons remain. In the system menu, those same options are available, and “maximize” is grayed-out.
If I double-click the title bar, the window resizes itself (sometimes just a little bit, sometimes more) and the “restore down” button is replaced by a “maximize” button. (In the system menu, “restore” is now grayed-out and “maximize” is available.) At this point I can now issue the maximize window command successfully. Alternatively, if I issue another place window command at this particular stage, e.g., “place window right,” to move the half-sized window to the opposite (right) side of the screen, the maximize button remains and I can verbally issue the maximize command successfully.
Fred

Fred F2012-06-02 11:59:24

In the system menu, those same options are available, and “maximize” is grayed-out.

I’ve seen this. Are you using Vista or Win7 (with or without UAC)?

Hi, Ron, I’m using Windows 7 with UAC set to “never notify.”

Will test.

Thanks.

Fred,

I figured out what you're doing. If you maximize an application window and then use the "place window " command, VoicePower assumes that the repositioned window is maximized.

I'll leave it to Ron as to whether or not this can be adjusted, but it is normal simply because VoicePower repositions the window in its maximized state. Under that condition, you can't maximize the repositioned window by voice command, despite the fact that that is a Dragon command and not a VoicePower command, because Windows sees it as being maximized. I can duplicate your problem very easily by doing the above. When we would have to do is to restore the application window to its original non-maximized format before repositioning it. Again, I'll leave it to Ron as to whether or not that's feasible and possible.

The reason that I couldn't duplicated is because I never maximize the window before repositioning it, or repositioned a maximized window because VoicePower automatically handles the application window alignment. It's a little bit like the doctor-patient joke:
Patient: Doctor, it hurts when I do this!
Doctor: Then don't do that.
What I would suggest for the time being as a workaround to ensure that an application window can be properly placed and resized is to make sure that the application window is not maximized before you issue the "place window " command. If you remember to do that, then you won't run into this problem. However, if you forget or you don't wish to do that, you can return the application window to its normal position and size by clicking on the Restore down button at the top right of the application window. This should put the window back to its original position and size before you maximized it. In other words, don't position a maximized application window. Let VoicePower handle the window positioning and alignment.
Chucker2012-06-04 00:32:21

Chuck and Fred,

Thanks for getting to the bottom of this!</font></p>

We’re releasing a major upgrade in the next day or two. - Will let you know when it’s available!

I fixed the problem. (It’s actually a workaround. Will keep working on this.)

rj & Fred,

We have spent some time trying to resolve this issue. Our attempts, in the manner in which we were trying to resolve it, turned out to be unsatisfactory.

However, in the process we discovered that there is already a method built into VoicePower, as well as Dragon itself.

Here's how it works. If you place an application window using the "place " and you originally had that application window maximized, you can restore it to its original position and size prior to maximizing it using the following commands:

Say: Restore (VoicePower)

If your version of VoicePower does not contain that command, you can use the Dragon commands:

restore [the] window

"the" is optional and this is the DNS Natural Language Command.

Either of these commands will restore the window in focus to its original size and location prior to maximization. Afterwards you can use the DNS command "maximize window" to re-maximize your application window.

Try this out and let us know what your experience is. We have found that this command works in both Windows XP and Windows 7 with both DNS 10.1 and DNS 11-11.5.

Chucker2012-06-11 16:11:00

Chuck,


Both of the methods you describe work well for me. Thank you!


Fred

Fixed this in the new release. Added a ‘Maximize’ (or maximize this or maximize this window) command.

You can download the release by following the link you received with your original order.