Look in Folder command

I have created a few of these commands and they are working quite well, however I cannot work out how to display a list of them similar to “Show My Favourites”. What do I need to say in order to achieve this?


Thanks


Graham


PS

When dictating a forum message, I have noticed on three occasions that the first time I say “new paragraph” the command is recognised as “new line”. After that it is recognised correctly.

Graham,


These are basically VoiceShortcuts commands. As such, they cannot be displayed as lists. I’m sure that something like what you’re looking for might be able to be added in the future, but it doesn’t currently exist. Here are some tips:


1. Always use easy to remember and short command names that are easy to remember, easy to say, and remind you of what location your opening. The technique that works most effectively is the same as for creating password hints.


2. You should keep a list of the command names, and if you wish, the full paths.


3. Remember that it is easier to copy and paste the paths when creating look in commands.


4. Remember that these commands only work in open/save dialogs. If you try to execute them anywhere else, you are very likely to get some bizarre results.


5. These commands can also be applied to the location for attachments in Microsoft Outlook.


I’ll leave it to Ron to respond to whether or not what you are requesting is possible. However, for the time being such is not available.
Chucker2010-03-02 17:25:46
Yes I do use simple names as you suggest, yesterday I simply couldn't remember whether I had created a command for a certain folder and thought I would be able to call up a list and verify, you are right that I can create my own record of these names somewhere, however it would be nice if this feature was implemented directly within VoicePower.
Graham

Graham,


One thing I neglected in my previous post was that even though there is no current way (command) to directly display the commands that you have created in the “Look in the folder” VoiceShortcuts, you can always do the following if you need to check any of these:


1. Say “create self programming commands”


2. Say “one open”


3. The list of your look in folder commands is displayed. Each item (number) contains both the Spoken Name and the full Directory Path.

This may not be as elegant as the list commands (show my favorites), but it least it gives you a listing that you can always check relative to each command that you have created.


Example:


1. Spoken Name: BackupDLL Directory Path: H:New Free UtilitiesOutlook backup DLL


So, the bottom line is that you can open up the list of these types of commands that you have created and see at a glance all of the information necessary relative to what you are looking for. In addition, you can also open any particular one to make any changes, or delete any one that you wish by simply opening it up and deleting the entries, then clicking or saying “activate”.
You have to say " OK" as well
[QUOTE=Chucker]
3. The list of your look in folder commands is displayed. Each item (number) contains both the Spoken Name and the full Directory Path.
[/QUOTE]
Having got this far, I can see the commands, however if I say, for example, "1 open", the dialogue box simply flashes and disappears. I can constantly reproduce this and it seems to be a bug. I can at least access the command if I say "1 activate".
Graham

Graham,

Although the screen doesn't disappear for us, WSR treats the open/save commands a little differently than Dragon NaturallySpeaking does. Therefore, saying "1 open" will highlight 1, but it won't necessarily open it. I'm not sure why the dialog simply closes for you. Is it for some reason forced into the background behind some other foreground screen? If not, see below.

Try the following and see if it works for you. It's fairly consistent for us in US English.

1. Once you get any of these dialogs to display, say the number and pause (i.e., 1 (one)).
2. Once the number that you want is highlighted, then say "OK".

See if that works for you and let me know.
..Chucker2010-03-06 15:03:31

I tried this out with no programmes open and was able to verify that the dialogue box is not hiding behind another application. Once I get to the list, saying “1 open” causes the behaviour previously described (funnily enough focus jumped back to Notepad where I am dictating this message and the command is recognised as text. When I try your solution, the number “1” is simply not recognised despite several attempts. I then tried with “2” and this time it was interpreted as dictation, again focus jumps back to Notepad. The only way round this is to say “show numbers”, as I said, however, if I use “activate” in place of “open” then my dictation is interpreted as the correct command.

Graham,

What does the microphone bar display when you say "1". If VoicePower is correctly recognizing what you say, then the microphone bar should display the entire line (i.e., 1. ). If it doesn't, and it disappears fairly quickly so you have to watch it closely, then WSR is not recognizing the command.

For example:

If you get to the "To create or edit a 'Move to Folder' command" and you say "1", you should get "1. Spoken Name: Folder Name: " displayed in the WSR microphone bar.
If you're not, let me know. That's how it's supposed to work up to that point.
Chucker2010-03-07 04:57:04

If I say just “1”, all I get is “what was that?”. If I say “1 open”, then I get the following:



“one open”, i.e. it is being recognised as a word and not a number.


Graham

Graham,

It shouldn't matter whether the microphone bar shows "open one" or "open 1". It should still highlight the option. If it doesn't, then that is a problem that we need to look into. On the other hand, if it does highlight the item, simply say the command again and it should execute.

Otherwise, the problem still lies somewhere within WSR. It could be a problem with UK English, but I would rather doubt it.

The only thing that I could suggest at this point is to keep trying and see if you find
a resolution. You can also try adding 1 to the dictionary, although I don't think that will solve the problem. Regardless, even with the idiosyncrasies of sometimes having to say the command twice to get it to execute, it does work on all of my systems running Windows Vista 32-bit and 64-bit and Windows 732 bit and 64-bit. Go figure!!!