List programs deflation

I have noticed that when I used the list programs command and the appropriate number, such as seven, the program which is displayed is the previous one in the list, in other words it shows number six. This has been occurring for a few days now and rebooting the computer does not seem to make any difference.


If I say ‘choose 8’ then ‘choose 7’ is shown in the results box, (and in Dragon’s recognition history). I am using Win7 Pro 64 bit, VC 12.66.2 and Dragon is up to date.
<div><br></div><div>Viv</div>
</div>
<edited><editID>k0065126</editID><editDate>2013-11-30 15:53:59</editDate></edited>

We haven't seen this before even though it's an old feature. Most likely explanation is that some file got corrupted.

Try uninstalling / reinstalling.

We have a new release (12.69.2). Install it and let me know if you have any more problems.


Thanks Ron,

<div><br></div><div>I figured that it might be a corrupted file and was waiting for the new release.  I will install that and see what happens.</div><div><br></div><div>Viv</div>

Viv,

This problem has nothing to do with VoiceComputer. I assume that you have installed the update for DNS 12.5.1 under Windows 7. This update is designed primarily for Windows 8.1, Microsoft Office 2013, and Internet Explorer 11.

Under Windows 7 it produces a bug in numbering such that with multiple text matches, Advanced Scripting commands, etc. that use numbered lists, anything after 1 selects the previous number. This does not occur in the Correction menu or the Spelling Window. This bug has been reported to Nuance. The problem does not occur with 12.5.1 (12.50.000.142) under Windows 8/8.1. It only rears its ugly head under Windows 7. If you’re not using Microsoft Office 2013 or IE 11 in Windows 7, then you need to apply the update and basically shouldn’t.

However, there is a workaround that resolves this issue. That is, don’t prefix number selections with “Choose”. Simply say the number and it will work properly. Unfortunately, Advanced Scripting commands that use numbered lists can’t be resolved using this workaround. For example, in KnowBrainer the commands “double list one” and “single list one” will work properly until you get to the next number. “Double list two” and/or “single list two” and beyond will always display the previous number. Therefore, if you have Advanced Scripting commands such as these, you need to use the next number after the number you want displayed. For example, “double list two” will be recognized as “double list one”. So, if you need “double list two”, you have to say “double list three” etc.

Note that the VoiceComputer commands that contain numbered lists are not affected by this issue. In the example above that you gave, “list all programs” will display this problem if you say “choose three”. You will get 2 displayed instead of 3. In this case, simply say the number by itself with no prefix (i.e., don’t say choose three, say three). You’ll find that this works correctly.

Just to emphasize again, this is not a VoiceComputer problem. It’s a Dragon problem and only those commands that are specifically Dragon related are affected by it. It only occurs with DNS 12.5.1 (12.50.000.142), but it does not occur if you’re using Windows 8/8.1.Chucker2013-12-01 21:07:07

Viv,


I didn’t carefully read your post, I assumed that you were referring to a VoiceComputer command.

I have an easy solution for you. Don’t use Dragon’s list command which Nuance copied from VoiceComputer.

Use VoiceComputer’s ‘Show Open Windows’ command instead. It’s not buggy like Dragon’s list command and is much more powerful

VoiceComputer’s ‘Show Open Windows’ command not only lets you switch between and close any open Window with a single voice command, it also lets you size and position any open Window on up to three monitors with a single voice command…

RonK2013-12-01 22:29:55

Thanks Chuck,

<div><br></div><div>I had assumed that it was a VoiceComputer command, and that the problem was not caused by Dragon, although I should have realised that it was Dragon causing the problem in view of what is displayed in results box.</div><div><br></div><div>Yes, you are right, I have installed all of the Dragon updates. As I do not have KnowBrainer then at least I do not have to remember those workarounds.</div><div><br></div><div>Thanks for the tip about not saying the word 'choose' in order to solve the problem.</div><div><br></div><div>Viv</div>

Ron,

<div><br></div><div>Thanks for telling me about the 'Show Open Windows' command. I will try to remember to use that in future.</div><div><br></div><div>Viv</div>

Just to emphasize again, this is not a VoiceComputer problem. It’s a Dragon problem and only those commands that are specifically Dragon related are affected by it. It only occurs with DNS 12.5.1 (12.50.000.142), but it does not occur if you’re using Windows 8/8.1.

A new VoiceComputer user here. Hi all

Unfortunately I have just encountered this issue on a computer with Windows 8.1 installed. I have created a test command using advanced scripting and it shows the behaviour as described above.
Even if I say “test 1” it will display in the recognition window “0”.

Funny thing is, I created a brand-new user profile (skipping the initial training) and the first time I tested the test command it worked. And then the bug was there again. Extremely strange.

Another computer (also Windows 8.1) where I briefly tested with a new user profile seemed all right. But I haven’t tried it again. Still need to do some more testing to get a grip on when this is occurring or what triggers it.
This could potentially be a major problem for many people using custom commands.

Update: I uninstalled Dragon and installed it again, updating to 12.5 without installing the latest patch.
The bug still occurred! I say: “test 8” and it shows one number lower in the recognition box (and the result).
Then I uninstalled VoiceComputer just to be sure and the bug persists.
I have now created another new speech profile (no voicecomputer installed, Dragon still at 12.5 basic) and the command works fine.
If I switch back to the profile where it did not work, it still doesn’t work.
Switch back to the brand-new profile: it still works.
Okay, so I went back to the profile where the command was not working. I deleted the offending command and created it again. Who knows… Unfortunately it is still not working.

So far it seems: somehow the profile breaks and when it’s broken, it remains broken (at least on my installation).

Anyone else experiencing anything like this? I am totally puzzled and quite at a loss.

Jan,

I have several commands that use numbered lists with DNS 12.5.1 (12.50.000.142) Professional running on two different versions of Windows 8.1. Both of these systems do not exhibit the bug.

However, the exact same user profile that works properly on 12.5.1 on both Windows 8.1 systems, when transported to Windows 7 64-bit exhibits the number bug. At the same time, if I take that profile under Windows 7 and transfer it back to either of my Windows 8.1 systems by overwriting the profile on those systems, the number bug does not occur.

It is entirely possible that part of the problem can stem from the user profile. However, a good working profile shouldn’t exhibit this particular bug except under Windows 7. This is how I originally tested and discovered the issue.

Thanks for your reply, Chuck.

Well, unfortunately my profile on Win 8 (having worked perfectly fine and never having ‘lived’ on a Win 7 PC) still does show this behaviour.
And it still shows this behaviour after removing the offending Dragon update.

Since you mentioned that VoiceComputer commands aren’t affected… is it possible to ‘hide’ my custom commands within the VoiceComputer xml files?

Jan,

While it’s possible to convert your custom commands to VoiceComputer’s XML format, you can’t simply just import them in their current XML format under Dragon. Dragon uses an entirely different schema and your commands wouldn’t work if you tried porting them over to VoiceComputer as is. It can be done, but it’s not a simple process. You would have to rewrite them using VoiceComputer’s XML format.Chucker2013-12-03 10:16:59

Jan et al.,

I have to back off on what I said originally. It appears that this little bug will eventually rear its ugly head even in Windows 8.1. Everything was working fine for me before but now I’m running into that particular problem with the declination of numbers. However, you simply use the workaround for multiple text matches (i.e., don’t say "choose #), just say the number. As regards to custom commands, there is no functional workaround except to simply say one number higher than the number you want displayed.

As I indicated, I already have submitted a bug report to Nuance, but it’s probably a good idea for everyone who runs into this to also do the same. More reports, the faster Nuance will consider the bug import enough to change more quickly. Click post replyChucker2013-12-04 12:51:22

Ron,


I like the ‘Show Open Windows’ command, but I have one minor comment to make which is that the list displays almost immediately, but then a couple of seconds afterwards an extra entry is inserted in the list for ‘VP List’.

This entry is not inserted at the very end but one or more positions before the end. I have found that, on occasion, when I am selecting one of the items near the end of the list, and just before the ‘VP List’ entry is inserted, then the number of the entry I wish to switch to has changed and I am switching to the wrong program.

At the moment I try to wait until ‘VP List’ appears in the list and then select my entry. Would it be possible to stop ‘VP List’ from appearing in the list, or to force it to be the last entry?

Viv

Viv,

This is due to the fact that commands are refreshed regularly. When you say “show open windows”, that opens a VP List with all the available open windows. However, the VP List dialog then becomes another open window and VoiceComputer adds that to the list of open windows during the refresh cycle.

I’ve noted this myself, but I’ve become accustomed to simply letting it refresh before opening any window option displayed. Then again, I’m used to the way VoiceComputer works and I understand that users may not be.

I’ll let Ron review and see what we can do.

Chuck,

<div><br></div><div>Thanks,</div><div><br></div><div>Viv</div>