Latest version randomly opening VoiceComputer

I’m running the latest version along with the microphone function which I love. Randomly, VoiceComputer opens up. I have to cancel it.


Interesting, don’t you think?

Ciao

As I mentioned on a previous post, I have the exact same problem. The program just opens out of nowhere even when we don’t want it to. That is something that needs a solution right away.

Jim & Gary,

Patience folks. We’ve been trying to figure out why, on some systems but not all, this particular quirk occurs.

  1. Basically, we are using Windows Speech Recognition (WSR) to turn the microphone on and off (SAPI 5.3) which is what allows us to toggle the microphone on and off, as well as automatically load VoiceComputer without even having to have Dragon loaded.

  2. This is basically a beta feature at the moment because we’re still trying to find the right sensitivity levels and we wanted to have our current users have the capability of trying it out with the understanding, as Ron posted originally, that it is a new feature which we are testing. We appreciate the fact that having the VoiceComputer Startup/Shutdown utility spontaneously launch is irritating.

  3. In addition, it doesn’t occur for everybody all the time. It’s intermittent, which makes it difficult to pin down. In addition, we’ve tried to keep it simple and straightforward vs. other known approaches to this feature, which are complex and also have intermittent problems like the VC microphone does.

For the time being while we track this particular issue down (note: we have a list of excluded words, but apparently what some users are saying is misinterpreted outside of these exclusionary rules). This is also what makes it difficult to pin down. For example, on my system (Coreâ„¢ i7 4770K with 32 GB of RAM, Windows 7 64-bit), this never occurs. However, on my Windows 7 32-bit, it does from time to time, but not consistently and not under all conditions which again makes it difficult to track. It does not occur on my Windows 8.1 (Lenovo Multitouch Twist with 8 GB of RAM). It does seem to be somewhat dependent on RAM (i.e., more prevalent on 4 GB of RAM vs. 8, 16, or 32 GB). It also seems to depend upon what’s going on under the hood and exactly how well the WSR engine that where using is able to correctly understand what you’re saying. In short, it could be anything. So, since this is brand-new, please be patient while we pin it down. Unfortunately, we can’t guarantee that we can solve it immediately.

On the other side of the coin, you can easily close the VoiceComputer Startup/Shutdown utility by simply saying “Cancel”. Irritating to have to do it this way, YES. Unfortunately, it’s necessary for the time being.

Lastly, please let us know how frequently it occurs on your system(s), and, if you can pin it down, where it occurs most frequently. You can check that by viewing the Dragon recognition history as soon as it happens to see what Dragon is recognizing. Note that when the Dragon microphone is on, it’s Dragon that is functioning even though the VC microphone is still active in the background. It might be a combination of the two. However, at this point we are pretty much shooting in the dark. Therefore, Patience is a virtue here.

I have just experienced my first shutdown on my desktop computer after dictating the phrase “space visited”.


Viv

Viv,

When you say “shutdown” do you mean that when you say the phrase “space visited” the VoiceComputer Startup/Shutdown utility comes up?

If so, one of the things that tends to make that spontaneous call up of the VoiceComputer Startup/Shutdown utility is using short phrases. We’re still working on this. Regardless, the longer the utterances (number of words in an utterance), the less likely this will occur.

In addition, this seems to occur when there’s too much of a pause between words. If you’re going to dictate a phrase that consists of three words or less, avoid pausing between the words because this can trigger it too.Chucker2014-06-20 16:47:30

Chuck,


Sorry, I should have been more specific. You are correct that when I said the phrase “space visited” the VoiceComputer Start-up/Shutdown utility opened up. (And when I was dictating the last sentence and said the word VoiceComputer the Start-up/Shutdown utility opened up again.)

Unfortunately, I cannot avoid dictating short phrases when I am translating from German as I sometimes have to do look up words, but I accept that I have to accept the consequences of that. However, in the instance I reported the Start-up/Shutdown utility opened as soon as I had uttered the word “visited” and before I had a chance to say the next words.

There is, of course, a problem when dictating punctuation as gaps need to be left before and after the punctuation in order to avoid it being taken as dictation. So I obviously did not leave much of a gap after saying the first word you for saying “visited” as the word space was taken to be dictation, rather than punctuation, which was what I had intended.

I will try to discipline myself to look up the words I need to know to try to avoid dictating short phrases.

Viv

Viv,

I understand. Unfortunately, there’s nothing we can do about that except possibly make the VC microphone less sensitive. Were working on that.

However, am I correct in assuming that you’re talking about dictating punctuation as requiring that you pause before and after? If so, that is absolutely unnecessary. All punctuation are what are called Dictation Commands, listed in the active vocabulary (Vocabulary Editor), and don’t require any pause before or after. The only reason that I’m bringing this up is that I always assume that this is a given in terms of understanding as far as users are concerned. So I may be misinterpreting you. Correct me if I’m wrong on that point.

The program just opens out of nowhere even when we don’t want it to.


In order to solve this problem we can no longer use the “Open VoiceComputer” command. We need to use a longer phrase or sentence to eliminate false positives. Something like: “Open VoiceComputer Controls”. Maybe an even longer phrase. like “Hal, please open VoiceComputer”.

Any suggestions?


How about:


1) VoiceComputer, do you feel lucky today

2) show me the money VoiceComputer

3) if you like VoiceComputer you can keep it

4) what difference does it make VoiceComputer

5) I could have been a VoiceComputer

6) explain Kim Kardashian VoiceComputer

7) explain Honey boo-boo VoiceComputer

8) Who is John Gault VoiceComputer

9) what’s it all about VoiceComputer

10)Why have a border VoiceComputer

I apologize to anyone who considers any of these suggestions politically incorrect. As far as I know, the First Amendment may still be in play. I did not check to see if any of these were copyrighted.

Thanks so much Ron and Chucker. I suspect we soon will have a feature in VoiceComputer that will analyze our dictation and correct our mistakes. In addition, I suspect the VoiceComputer skunk works is also creating a quantum computer that will change everything.

Jim

Jim,

Quantum computers should be available by Stardate 4607.2.

Ron,

How about just that? "Open voice computer command"

But, I am suspecting your bug is much more serious than that. The program is opening even without any DNS program on. In other words, I don't think it's listening to anything that would cause it to open. Unless, the built-in computer microphone is listening by itself. I had a situation last week where I turn my laptop on getting ready to work on an Excel spreadsheet and I did not even consider opening DNS. Suddenly, something was triggering voice computer to start the process of opening DNS without any intervention on my part. I could not stop it. It just repeatedly came back.

Chucker,


Article on one is Detail magazine this month. The D Wave but your time estimate is probably correct.

Jim

But, I am suspecting your bug is much more serious than that. The program is opening

> even without any DNS program on…Unless, the built-in computer microphone is listening by itself.

That’s exactly what it’s doing. The VC Microphone is always listening. It’s using the built-in speech recognition in SAPI 5.x. It has nothing to do with Dragon. (VoiceComputer has always been able to work with WSR and doesn’t need Dragon. In fact, it’s incredibly fast with WSR but Dragon is far and away the better speech engine since Microsoft has never tried to compete, leaving us to cope with the Nuance monopoly.)

We could add levels of complexity to the VC Microphone feature to fix the problem (training, etc.) but first I want to try two other approaches:

1) A longer phrase to activate it. Something like “Please open VoiceComputer”. The phrase may even need to be longer, something like, “I would like to control VoiceComputer.” A long phase should let the system understand you 99.9% of the time and make it highly unlikely that the system should accidentally understand the command.
2) Two command words, with a distinct pause of up to 4 seconds between the command words, e.g. “VoiceComputer” [pause] “VoiceComputer”. This might accomplish the same thing as 1).

Tomorrow I’m going to start testing the “I would like to control VoiceComputer” command and see if it fixes the problems.






That sounds like a plan. For the first time in two years I had to uninstall VC as it got to the point where it was disruptive. I was on the phone this morning working with someone, and in the middle, the program strated opening repeatedly. I would be happy to beta anything you have.

There’s no need to uninstall! Just right click on the VC MIcrophone in the System Tray and select close. If you placed VC Microphone in Startup, remove it by saying “Configure VoiceComputer”, then “3 Open” where “3” is ‘Add | Remove VC Microphone from Startup’ and then ‘Yes’ to remove the VC Microphone from Startup.


Gary,

I concur with Ron on all points. However, we gave all of you the version that contained this feature because we needed your help in finding where the “black holes of Calcutta” are, so to speak.

Because of you all, we’re getting a better handle on this. With your help and a little patience while we perfect this feature. As Ron points out, we want to avoid making this feature overly complex.

“Better a diamond with a flaw than a pebble without one.” - Chinese ProverbChucker2014-07-01 07:42:19

Understood. I just reinstalled and removed from startup.

Chucker:

It was "Wired" rather than "Detail" Magazine.

Jim

Chucker:


This is been happening about every two minutes today. I’m attaching the Dragon recognition history.

Hopefully this will help you run down the problem.

Enjoy your 4th.

Jim
uploads/33/Recognition_History.txt

We have a new version that we hope to release within a couple of days that seems to fix the problems.

In the meanwhile, just close the VC Microphone by right clicking on the VC Microphone icon in the system tray and taking it out of Startup.