Installation – configuration

Windows 8; 64 bit; 16 GB RAM; Core i7 processor; long-time user of Dragon NaturallySpeaking Professional (12.5);

I’ve had just a few instability and speed issues, with one of the most notable slow responses being after the “Show Numbers” command, when it seems incredibly slow to recognize “click” whatever number I am choosing.

In reviewing the release notes, installation notes, readme first notes, I now have a few questions:

  1. In reference to the need for Net Framework 4.0 or later, although it appears that I already “had” net framework 4.5 under my Windows features, the expanded features list shows very little checked:

    Do some of these sub features need to be turned on?

  2. The release notes also make reference to “5) VoiceComputer needs to run in ‘highest-available’ mode in Vista, Windows 7
    and 8 . . .”, but when I look at the task manager details, this is what I see:

    Would this be correct?

Thank you, – John Staudt

John,

1. I don’t think that you need to turn on any Windows features, but I’ll check into this.
2. This seems to indicate that VP.exe is running in elevated mode, as it should be. Am I missing something?

What i7 processor are you using?

Are you using BestMatch V? If so, you should switch to BestMatch IV.

If you’re using BestMatch IV, change speed v accuracy to fastest. If this doesn’t work, we need to figure out the problem.

BestMatch V is slow if you use a lot of commands. In my testing, it didn’t make any difference whether the commands are added directly to Dragon or are run through VoiceComputer, large command sets slow down BestMatch V user profiles.
Chuck can speak to the accuracy differences between BestMatch IV and V but I understand that the differences are very minor with use.

If you want to use BestMatch V, we can help you reduce the number of commands that are enabled. There are tens of thousands of mouse commands, show numbers commands and super numbers commands. We can review which ones you need and delete the rest, thereby speeding up VoiceComputer / Dragon.

John,

Ron is correct. You do not need to change any of the settings for net framework. If the current settings are not correct, then VoiceComputer will launch or run.

Second, make sure that you are only enabling those VoiceComputer commands that you actually use and need. If you don’t need or use some of these, disable them, keeping in mind that you have to restart VoiceComputer whenever you make changes to the #17 for enabling or disabling VoiceComputer commands in the “configure VoiceComputer” dialog.

Third, BestMatch V might be the desired speech model, but BestMatch V requires two cores to be available simultaneously vs. BestMatch IV which uses two cores sequentially. Anytime that you’re running Dragon and/or VoiceComputer on a system that doesn’t have four cores available, you’re going to get slow performance with BestMatch V. I’ve been playing around with BestMatch V vs. BestMatch IV and I have not found that over time BestMatch V is any better than BestMatch IV in terms of overall accuracy. I’m dictating this post with BestMatch IV and getting virtually 99% accuracy. Then again, I’ve been using BestMatch IV for a long time. My system is conducive to running BestMatch V with VoiceComputer and numerous Advanced Scripting commands (DNS 12.5 Professional) with very little slow down. However, I’m running a Coreâ„¢ i7 4770K with 32 GB of XMS 1866 MHz RAM and overclocked to 5 GHz. Nevertheless, I prefer BestMatch IV because there is no latency and my accuracy is as good as or better than BestMatch V. You might want to try creating a new user profile using BestMatch IV General-Large. You will find that you can set the Speed vs. Accuracy slider all the way to the right (100% – Most Accurate).

How well Dragon and VoiceComputer perform is really predicated upon the specific Coreâ„¢ i7 CPU that you’re using. Therefore, it would be a good idea if you would give us the model number (CPU processor number). Or, you can attach a copy of your Dragon log so that I can look at your overall system configuration. If you can’t figure out how to attach your Dragon log to a post on this forum, simply send it to me at Chuck@VoiceTeach.com.Chucker2013-10-03 11:05:34

Thanks. For the most part, it has been working fine.

Primarily, the problem has been with the “show numbers” command – the slow response after the numbers are up on the screen.

No problems with the mouse (screen grid) or super numbers commands.

For the time being, I had primarily wanted to make sure that I had installed it correctly. I may take a look at using BestMatch IV in a few weeks – as it seems I may be borderline on the speed for BestMatch V:

Thank you for your help, – John

John,

Your hardware configuration should be adequate for using BestMatch V Medium vocabulary. However, you might try moving the speed be accuracy slider all the way to the left (i.e., 0% or Fastest Response) and see if that improves the performance of Show Numbers.

On the other hand, you can also edit the “Enable | Disable VoiceComputer commands” and make sure that you are not selecting commands that you don’t or will never use. The more commands that you load, the more you can introduce latency, particularly with DNS 12.5 Professional. Another problem that you may run into is the number and type of Advanced Scripting commands you may be using. Some time ago it was determined that with BestMatch V if you have a very large number of Advanced Scripting commands or you have Advanced Scripting commands that have large lists (i.e., greater than 50 to 100 items in a list), this will create latency issues with BestMatch V.

Regardless, your hardware configuration should be adequate for running BestMatch V because you have at least four cores. I don’t have any problems with the speed of Show Numbers on any of my systems, even with BestMatch V on my Coreâ„¢ i7 4770K.