focus between monitors

When I am using monitor number 2, I can give the appropriate order and focus to monitor 1. However, the converse is not true. When I am using monitor 1, the appropriate order with either monitor or screen only moves the mouse a little bit but does not focus it monitor 2.


I like this feature but would like to get 100% of it rather than 50%. In other words, I want the full loaf.

Any help would be greatly appreciated.

Thanks,

Jim

Jim,

I’m not completely clear on exactly what you mean by “focus” relative to monitor 2 or monitor 1. There are a number of ways that you can move between multiple monitors, but I need to understand exactly what you mean.

Thanks for getting back to me, Chucker:


I am trying to switch between two monitors. I can get from monitor 2 to monitor 1 but not from monitor 1 to monitor 2.

Thanks so much.

Enjoy your weekend.

Jim

Jim,

OK. That makes it a little clearer, but it would be helpful if you were to explain how you’re trying to get from one monitor to the other.

One thing you can try is using the Mouse commands. However, make sure that you have the Mouse commands enabled as well as the setup for multiple monitors both in the “configure VoiceComputer | Enable or Disable VoiceComputer commands”. You need to make sure that you have a checkmark for Mouse Commands and Mouse on 2nd/3rd Monitor.

Once you are sure that those are set up and you set up VoiceComputer for both monitors (i.e., Configure VP Mouse Commands for 2 or 3 Monitors) following the instructions and making sure that the mouse pointer is in the exact upper left and lower right positions on monitor 2 when you configure such, then you can switch back and forth between monitors by remembering that monitor 1 doesn’t have any special mouse commands, but monitor 2 does. For example, to position the monitor on monitor 1 when you are on monitor 2, you simply say “mouse 20 at 20”. That will put the mouse pointer on monitor 1 at X/Y coordinates 20/20 based on the Screen Grid locations for X/Y coordinates. From that point you can move the mouse anywhere using the small increment mouse commands or large increment mouse commands depending upon what you need. Or you can switch between active Windows on any monitor by simply saying “place focus left | right…”. You should review those commands. you want to move to monitor 2 from monitor 1, you would say “mouse 20 at 20 on screen 2”. Once you get to a particular monitor you have any number of ways of placing the focus on any window using either the mouse commands or the navigation commands, yada yada yada.

There’s much more that you can do once you get the hang of it. I think I’m going to do a demo to include with VoiceComputer show users how to use multiple monitors. We just never had a user expressly need for clearer understanding or demand for such.Chucker2014-03-22 10:31:47

Thanks, Chucker:


Reconfigured everything again. If I have the mouse on monitor 2, which is my left monitor, both the commands “`place focus right and place focus monitor 1” work. No luck when the mouse is in monitor 1.

As you probably know, I found the “place focus monitor #” command under “desktop control” in the "switching commands."

I suppose this is happening because I am not a member of the left.

As always, much appreciated.

Jim

Jim,

Up to this point I hadn’t tried the “place focus” commands for monitor 1 or monitor 2. It looks like the “place focus monitor two” is recognized but broken.

I’ll have to pass that along to Ron for testing and correcting. Until then, I suggest that you use the “mouse X at Y on screen two”. I’m still trying to test whether or not there are any conditions that preclude proper functioning.

There is no bug, you just need to read the documentation!


(Need to configure VoiceComputer screens for two monitors to use the monitor to commands.)

Show Voice Windows, Basic Switching Techniques (Show Section 1)




Ron,


Thank you for getting back to me. I have the monitor command configured. I also printed the basic switching techniques page and have it in front of me. The command works when I am placing the focus to monitor 1 from monitor 2. However, when I am attempting to place the focus in monitor 1 to monitor 2, the mouse moves a little bit but stays on monitor 1.

Let me know if you have any ideas.

Much appreciated,

Jim

Jim,

I’ve tested this out and I have informed Ron that your experience is the same as mine. However, for the time being I use the mouse commands to place the mouse pointer on the respective monitor and also for dragging applications from one monitor to the other and vice versa.

I’m going to be making some recommendations with regard to improving these multiple monitor commands.

You simply need to configure the VoiceComputer help system to display on two monitors. I will change this in the near future but that’s what the focus command needs at this time.

Ron,


I appreciate that Emerson said “a foolish consistency is the hobgoblin of little minds” but I configured the monitors as directed. I even closed out of voice computer and shut down the computer. It still works when I go from monitor 2 to monitor 1 but when I try to go to monitor 2 from monitor 1, the mouse just moves a little bit.

Thanks.

Jim

Ron and Chucker:


Chucker’s suggestion I use the mouse movement commands such as when I am on monitor 1 “mouse 20 at 20 on-screen 2” does deploy correctly. Of course, for me, the place focussed command will be much easier.

I do not know if this says anything about the configuration between the two monitors or not. However, I did follow the instructions very carefully.

Thanks,

Jim

Jim,

Doing the following:

Configure VoiceComputer
7 open
1 open (configure VoiceComputer’s screen display)
2 Open (change VoiceComputer’s display width)
no
Two Monitors
Ok

Restart speech

What you need to do is to completely shut down VoiceComputer and Dragon so that you give VoiceComputer a chance reconfigure itself. That is, you need to wait until you get the dialog box that says “configuring VoiceComputer”. Until you do it won’t work. Once VoiceComputer has reconfigured itself for two monitors as described above, when you say “show main menu”, the main menu will open on monitor two. Normally you can say “resize window” because the main menu opens full screen. In this case simply say “Resize to one half”. Then you can say “hide VoiceComputer” if you want. However, whenever you reopen the main menu, it will open full-size and you will have to do the same as described above (i.e., resize to one half or resize to one third, yada yada yada).

Once you do this you can use the commands to place focus to either monitor using the place focus commands for multiple monitors. However, let me know if you have any problems where the commands don’t work because I’ve only just tested it in one session and we need to make sure it’s consistent.Chucker2014-03-28 10:39:52

Chucker,


Thank you for getting back to me. I followed your instructions and shut down voice computer. The dialog box popped up saying it was being configured. When I redeployed voice computer, the main menu open full-size and monitor one. I went through your instructions a second time and then close the computer completely. The command still do not work.

Let me know.

Enjoy your weekend,

Jim

Jim,

You might have to work on it a little bit, but it works for me. Having set it up correctly, I can now switch back and forth between monitors and when I say “show main menu” it displays on monitor 2.

The only thing that I can think of is that you may not have your monitors set up correctly. If you go to the Windows Control Panel | Display | Adjust resolution, where is your monitor one in your monitor 2 and which one do you have set up as monitor 2. Monitor 2 should be your left monitor and monitor 1 should be your right monitor. In addition, monitor 1 should be your main monitor. Also, what are the other settings. For example, when I originally set up my monitors, I had the DVI plugs reversed (desktop) on my display adapter (video card). I had to switch them to get it to display correctly.

FYI:


I’ve changed these commands in the next release. (Beta in a few days.)
You’ll just need to configure VoiceComputer for mouse on two or three monitors.

Thank you, Chucker:


I couldn’t find how to designate monitor 1 my main monitor. However, I did find that the monitor that displays the Windows taskbar is the primary monitor. The taskbar is on monitor 1. Monitor 1 is my new high-performance laptop.

I believe I have the monitor 2 set up with the VGA. I think it is the smaller of the two insertion points. I have an adapter to use the larger insertion point but for whatever reason it won’t insert. I checked the pins and they should go in. They don’t. I don’t want to force it.

I assume the HDMI insertion doesn’t work for any thing but videos. Is that correct?

Thanks.

Even though I cannot stand delayed gratification, since Ron is going to fix this problem in a view days I am not going to go out and buy a new adapter to replace the one that doesn’t fit nor an HDMI cable. But with you on the case (the Sherlock Holmes of all things voice recognition and computers, something tells me you will figure it out before the new beta comes out.

Appreciated.

Jim

Thanks, Ron,


Jim