Fill and font commands inconsistent in Excel

I am not sure if this is to do with VoiceComputer commands.


I have the option to say click before pressing a button enabled.

In Excel 2010 when I have one or more cells selected and issue the command ‘click font colour’ then the colour of the font changes to whatever colour is currently selected on the change font colour drop down button.

However, in order to change the fill colour of a cell I have to say ‘fill colour’ then ‘click red’. If I say ‘click fill colour’ then that text is inserted into the cell. Is this an inconsistency in VoiceComputer, and if so can it be changed?

Viv

Viv,

First, why Nuance added those two options to the Dragon Options dialog | Commands tab has always been a mystery to me.

The reason is:

  1. Require “Click” to select menus is of little use in cases like Adobe Acrobat where access to the menus is not accessible by voice anyway. That is, you can say “click file”, “click edit” etc. in Adobe Acrobat until the cows come home and you won’t be able to access the menus by voice anyway. The only way is either by saying the Hotkey, or using VoiceComputer.

  2. Require “Click” to select buttons and other controls generally won’t help you in cases like Quicken or QuickBooks where those command dialogs aren’t accessible by voice anyway. Same issue as related in #1 above. In these cases there are no Hotkeys so VC is one of the only options.

Both settings don’t give you any advantage and basically and an extra trigger word to commands affecting these options which usually don’t work anyway. That is, you end up saying more vs. less. If you don’t have these two options selected, you can still say “click” if you think that will help recognition under the conditions specified by these two options, but the bottom line is working smarter, not harder. Why add an extra command word when in many cases it won’t work anyway and in all cases where you have a problem accessing menus and commands, you can say click anyway without having to these options enabled.

Whether you are using Excel 2010 or Excel 2013, the way that the command buttons work on the Ribbon bars is the same. That is, some are accessible, such as “font color”, and some are not, such as “fill color”.

However, that being said, the one feature of VoiceComputer that you can use to select fill colors is “Show Numbers/Display Numbers”. When you’re in Excel and you use the “show numbers” command, you will see that each of those two options are assigned to 2 numbers. The first number selects the assigned color, the second numbered drops the drop-down list and subsequently numbers each option in such.

The way that I set up my numbers display control is to select “small font” and make the transparencies settings 20. If you do it that way, then all of the numbers displayed when using Show Numbers/Display Numbers will not overlap each other. For example, and the numbers do change, the first number directly over the fill color or font color will be one of the numbers selectable. The number to the immediate right will open the drop-down list box and number all of those options, from which you can select whatever you wish.

The bottom line is that it isn’t a problem with VoiceComputer as much as it is a problem with Dragon itself relative to these commands. I suggest that you use Show Numbers/Display Numbers, which is what I do in these types of situations.Chucker2014-04-03 01:00:56

Chuck,


Thanks, I suspected that the commands were not to do with VoiceComputer and I cannot imagine that Nuance will do anything to change them.

It was some time ago that I decided to enable the ‘click’ option because it solved a problem I was having, but I cannot remember what the problem was or which software I was using, so I have now changed to not requiring the click command, as you suggested.

I think I will stick with the method I am now using, namely space ‘fill colour’, ‘red’ which seems simpler than saying ‘show numbers’, ‘72’, ‘71’, but I use the ‘show numbers’ in other cases where I find it very helpful.

I have never used Quicken or QuickBooks and when using Acrobat Reader I tend to use the mouse anyway, as I don’t use this software very often.

Viv

Viv,

First, you do want to Enable HTML support, Enable commands in HTML Windows, and Require “Click” to select hyperlinks in HTML Windows. These are important to keep you from inadvertently accessing links when you don’t want to, as well as to be able to use commands in HTML Windows. The other Require “Click” commands are unnecessary and not particularly useful. I only gave you the examples of QuickBooks and Quicken along with Adobe Acrobat as examples, there are numerous others.

The method that you’re currently using is fine for standard colors (i.e., red, blue, green, yellow, dark red, magenta) but if you want to fill using any other types of colors it won’t work the way you currently use it. That simply because Dragon only recognizes the base colors in this context. The same applies to font styles (i.e., Dragon Only Recognizes Six Basic Font Styles, Such As Times New Roman, Times, Courier New, etc.). That’s why I use Show Numbers/Display Numbers. For example, try saying fill color, light green accent three. It won’t work. But, if you’re using the standard colors understood by Dragon, it will work as desired.

Nevertheless, If it ain’t broke, don’t fix it is the model that I go by.Chucker2014-04-05 09:19:21