Excel move commands doubled

I am using version 12-51-2 of VC, Excel 2010 32 bit, Wind Pro 7 64 bit. When I say ‘left 4’ the focus moves eight cells. Every command to move left, right, up or down moves twice as far as I want.


Re-booting the computer, or switching off and then on again, does not solve this problem.

Any ideas? Is this a Dragon problem or is it VC which is not functioning correctly?

I did try to look at the Dragon help files. I can display the index and see topics in the Search tab but nothing displays in the right hand screen. Very odd.

Viv

You’re using an extremely fast processor that runs at twice the speed of anything I’ve ever seen :slight_smile:

I can’t duplicate this.

Try the commands in Microsoft Word and other programs and try the Dragon commands: Move (up/down/left right> 1-20.

It’s not going any faster than it did a few weeks ago, when the commands worked perfectly. :slight_smile:


The Dragon commands work fine, and fortunately only being able to move 20 cells of the time is not a problem. The command works faultlessly in Word, but I cannot think of any other programs I might use where I would use this command. I tried again in Excel after it worked in Word but still found the same problem. Very odd.

In a way I am glad that you cannot replicate it as it presumably means that I am the only one affected. At least using the Dragon commands will enable me to do what I want, as long as I remember to use them.

Viv

Viv,

I can’t duplicate this either in either Microsoft Excel 2010 or 2013.

When you issue the command in an Excel, what does the results box show?

Chuck,


The results box shows the correct command. I also checked Word 2010 and the results box shows what it should and the focus moves the correct number of cells. It is only Excel 2010 which exhibits this problem, as far as I am aware.

Viv

Viv,

What happens when you say “move right four”? Do you get the same results? Just trying to figure out where this is coming from.

Chuck,


‘Move right four’ moves the focus 4 cells, as expected, but ‘right four’ moves eight cells.

All commands, when preceded by move, work correctly, but if I say left, right, up or down without saying move first then the focus moves twice as many cells as it should.

Viv

Viv,

Have you created or do you have any custom commands that you or someone else created that use the command name "right | left | up | down <1-##>. Keep in mind that legacy Dvc scripts and custom Advanced Scripting macros/commands take precedence over Natural Language Commands minimize.

It may be difficult to pin down, but even though the command name that shows up in the results box is correct, the command that it is executing may not be. That’s what we need to figure out.

If I may offer a suggestion.

Since you have alternative commands that work, let’s just wait until the next release and try again.

When it comes to computers, the perfect is always the enemy of the good.

They will drive you mad if you let them.

Chuck & Ron,


I do not have any custom commands using left, right, etc.

As I still have the problem, which seems to be unique to me, that if I shut VC down and leave Word and Excel running then they crash, but everything is OK if I shut Word and Excel down before VC, my guess is that something on my computer is interacting with VC or Dragon or Excel and causing the problem.

When I have some time I will see if the problem exists on my laptop as well. The other thing I could do, when I have nothing else to do, is to disable every start-up program which is not essential and see if the problem goes away. Not something I look forward to doing.

Thanks to both for your help,

Viv

PS I decided to delete office2010_custom.xml after closing VC & Dragon, then open both programs. The left, right, etc commands work correctly. I then reinstated office2010_custom.xml from the backup copy I keep for when I install a new version of VC and then reopened VC and Dragon and the commands still work correctly in Excel. That is weird and makes no sense!!!

I have to say that I have found in the past that this problem does seem to be intermittent and sometimes restarting Speech solved the problem, although not always for very long. It does seem to be one of those problems which cannot be solved because they are not reproducible.

Viv

k00651262013-08-22 11:34:00

Viv,

I’ve managed to duplicate your problem and I am going to communicate that to Ron. I’ll give you more feedback on it once I’ve had a chance to discuss it with him.

Chuck,


That’s great, and thanks for continuing to look at the problem.

Viv

Chuck,


Is the problem solved in the 12-53-1 version, or am I just lucky that the problem is not occurring at the moment?

Viv

Viv,

According to what I have discovered, you’re just lucky.

Try saying down 100 and you’ll find yourself ending up on cell 201.

We’re still looking at this.

You’re right Chuck,


It was just a lucky fluke as I am back to doubling mode now.

Viv

Need to confirm this.

The VC command set is down 1-20, 30, 40, 50 (also up, left, right…)

All of these commands are doubling in Excel and only in Excel?

(Chuck’s Down 100 problem has to be one of his own commands, VC doesn’t have that command.)

Ron,


In Excel ‘down 1’ sometimes moves the cursor down 1 cell, other times it moves down 2 cells. I have just tried it in Excel, where it move twice as far as expected, and in a table in Word it moved the correct number of cells, so it looks as if the problem is just with Excel.

I have just tried ‘down 100’ and this moved the cursor from cell A1 to cell A201 in Excel 2010, as Chuck predicted. I have not created any command to move the cursor 100 cells in any application.

Viv

I can’t duplicate this so I don’t have VoiceComputer configured the way you do.

What version of Excel are you using?

and, could you email a screen shot of VoiceComputer’s enable|disable screen?

Viv et al.,

This is just FYI to let everyone know that we seem to have solved the problem regarding moving cells in Excel.

Once we are absolutely certain that the problem is resolved, we will provide update.

New version of VoiceComputer, 12.54, fixes the doubling problem and can be downloaded from our site.