Dragon hangs at splash screen

Over the last week or so there has been a series of reports of Dragon hanging at the splash screen.

If you are experiencing this problem, particularly because it prevents VoiceComputer from loading, note the following explanation.

It appears that, for whatever reason, a recent Windows update is causing anywhere from 2 to 10 minutes delay at the Dragon splash screen. It may appear that Dragon NaturallySpeaking is hanging up at the splash screen, but if you let it go, Dragon will eventually load.

What appears to be happening is that if users have a checkmark in the Administrative Settings… | Miscellaneous tab | Check for product updates at startup, this setting causes Dragon to check for updates when loading Dragon NaturallySpeaking. There is no easily identifiable reason why this should occur. However, what does occur is that Dragon will not load until either the Check for product updates is complete or it times out and allows Dragon to continue loading your user profile.

To correct this problem, make sure that Dragon is loaded but your user profile is closed. Then, click on the Tools menu on the DragonBar and click Administrative Settings… Go to the Miscellaneous tab and remove the checkmark from the checkbox for “Check for product updates at startup”. Click Apply and then click OK to close the Administrative Settings dialog.

Lastly, restart Dragon by itself to make sure that the change to the administrative settings has taken effect and the Dragon loads without delay. Once you are sure that it is loading normally, then simply say “open VoiceComputer” or double-click on the VoiceComputer shortcut (icon) and select or say Restart Speech.

VoiceComputer and Dragon should now load properly.

If you have been looking at this particular issue in the KnowBrainer forum, ignore the technobabble (i.e., psychic debugging).

Thanks Chuck,


It had not occurred to me that Dragon was taking longer to open than normal, but I have followed your advice and it opens up more quickly now.


Viv

Viv et al.,

It sometimes takes longer on some machines than others. For example, on my Core i7â„¢ 3770K under Windows 7 64-bit the delay was only about 10 to 15 seconds. On my laptop, which is a Toshiba Satellite Coreâ„¢ i7 2670QM, under Windows 8, it was long enough to prevent VoiceComputer from properly loading.

Regardless, it's become more prevalent of late, and the resulting latency has increased. Nonetheless, this whole experience is a good reason for disabling "Check for product updates on startup".

FYI

My guess that the original reason for the hangup at the splash screen being a problem relative to a recent Windows update was not correct, and I apologize.

The actual reason is that Nuance is preparing the DNS 12.5 update patch. However, the update server (Software Manager) is not accessible at this time Re: this update.

At the current time you are, or will, received the error message from the Software Manager that the:

Available Software Update
Download Failed

Either you are not connected to the Internet or the FLEXnet Connect servers are currently unavailable.

Click Retry If You Know That You Are Connected to the Internet.
Click cancel to skip the check for updates.

Nuance has posted the following technote that explains the problem and how to resolve it, which is what I originally posted above.

DNS splash screen hanging

Everybody, including myself, is impatient for the 12.5 update. Unfortunately, were all going to have to wait until Nuance has resolve this particular problem, whatever that may be. So, in the interim the only thing that you can do is to turn off the "Check for product updates in the Administrative Settings…, and just periodically check for updates from the DragonBar, Help menu until the problem has been resolved and the download is available.

For those who are interested in what the DNS 12.5 update patch will fix and/or resolve and who have not already seen the PDF file, you can access it from the link below:

Dragon NaturallySpeaking 12.5 Release Notes.pdf

<edited><editID>Chucker</editID><editDate>2013-02-23 09:45:21</editDate></edited>