Desktop search commands in Windows 7

I know this forum is all about VoicePower so apologies for this question which is about DNS. It’s just that you guys are such great programmers, I’m sure you’ve got some insights on my issue (flattery!)


My issue is below. I posted this issue on a speech recognition forum but some alternative scripts that were offered wouldn’t work for me. I know that VoicePower will complete these same actions in a heartbeat but I’m intrigued as to why the below -mentioned out of the box commands described below don’t work any more in DNS.


<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>I installed DNS Pro 10.1 on a new Windows 7 laptop of mine with 2.2 GHz dual core and 4 GB of RAM. Performance is impressive. One small glitch though.
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal><?: prefix = o ns = “urn:schemas-microsoft-com:office:office” /><o:p> </o:p>
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Commands such as “search the computer for X”, “search documents for Y”, “search e-mail for Z” worked really well with lightning fast search results back when the laptop was new. Much faster searching compared to executing the same commands with DNS pro 10.1 on Vista!
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal><o:p> </o:p>
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Then, all of a sudden, these same commands stopped working? What happens is that the search results screen flashes up for a very brief instant and then disappears.
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal><o:p> </o:p>
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>I noticed this loss of feature the day after Windows Update installed routine updates for Windows 7. However, the commands still worked fine immediately after the updates and before shutting down.
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal><o:p> </o:p>
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>I tried the following with no luck:-
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal><o:p> </o:p>
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Tried with several different microphones
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Did a repair re-install of DNS 10.1 Professional
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Turned off my AV software (McAfee)
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Turned off my firewall (McAfee)
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Disabled Google search plug in IE8
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>At all times, the checkbox for enabling desktop searching under the commands tab of DNS’s options has been checked (enabled).
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal><o:p>
</o:p>I tried seeing if I could vet the commands in Command Browser. I can see them under “voice shortcuts” but they are not editable as they are built – in Natural Language Commands.
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal><o:p> </o:p>
<P style=“MARGIN: 0cm 0cm 0pt” =Msonormal>Any ideas what could be stopping these neat commands from working?






I recently did some support work on DNS for a client with a new Windows 7 installation and these commands worked great for him.


Thanks


Peter

I just installed the latest release of VoicePower just now for the first time on the new Window 7 laptop and tried the VoicePower commands below but none of them worked. Same behaviour as mentioned in the previous post i.e. the Windows 7 search window flashes up instantaneously and then disappears:-


Search the computer for

Search email for

Find documents for


Peter

Peter,

I've been through all the Dragon and VoicePower search commands (latest version of VoicePower) and can't duplicate your problem.

The first thing that I would suggest that you try is opening up the DNS Options dialog and do the following:

1. Make sure that all of the commands in the Commands tab search options are selected. I would assume that they are in your case. However, unselect them and then re-select them and click Apply, then OK.
2. Click on the Natural Language Commands button and do the same for all the Natural Language Commands.

Let me know if that has any effect. I found at least one case at one time where some of these commands needed to be disabled and then re-enabled in the DNS Option dialog.
Otherwise, e-mail me a copy of your Dragon log. We'll go from there. Your problem is kind of strange because I have two systems running Windows 7, one 64-bit and one 32-bit. All of the search functions work on both systems. You got me scratching my head a little bit on this one. Unfortunately, since I can't replicate the problem, I have to rely on your observations as well as the above suggestions to start with.

Chuck


Thanks for these ideas.


I followed the instructions but unfortunately the problem is still manifesting.


I’ll send you the DNS log.


Thanks


Peter

Peter,

There is nothing in the Dragon log that points the finger in any specific direction. The only thing that is there are references to shutting down these commands. However, they are associated with DNS shutdowns, which leads me to believe that they are only being disabled because your closing Dragon NaturallySpeaking.

Have you tried running a repair of DNS?

Since there is nothing indicative in the Dragon log to indicate that there is a problem, these commands are simply failing to execute. I don't recall off the top of my head reading your e-mail whether or not to commands are being recognized in the results box (i.e., blue border). If so, then try a Repair. If not, try using the command hot key or switching to command mode. Either one of those should produce <???> if the command fails.

Since it's difficult for me to replicate the problem, we'll just have to take it step-by-step until we find the root cause.

Chuck,

I have tried the repair route (see my starting post in the thread) but this did not resolve the problem.

The search commands are definitely being fully recognised. They come up with the exact command word content in the results window with a blue border.

The search window flashes up on the screen for an instant and then immediately disappears. It's like something is conflict in with the execution of the command. Either that or could it be that the command is executing too quickly for Windows?

Thanks

Peter

pmaddern2010-03-03 02:14:35

Nuance Support told me yesterday that they were able to recreate my issue. The agent went into Windows Services and stopped the Windows Search service. After this, anytime he used Dragon Naturally Speaking to search, a search box would quickly come up and then disappear.


His thinking was that, from the sound of it, the Windows update may have stopped this service and failed to restart it afterwards.

He asked me to go to Control Panel -> System and Security -> Administrative Tools -> Services Browse down to Windows Search and check on the current status. If needed, to change the Windows Search service to Automatic (Delayed Start), and make sure the Status is showing Started.

When I got this e-mail, I thought "this is the answer".

However, on checking my system, the search service was set on Automatic (Delayed Start) and status was showing started. I stopped and restarted it to see if that would trigger things but these commands still wouldn't work.

I'd love to know what is preventing/interfering with/disabling these Natural Language Commands as they’re such excellent commands, not just for helping me run the Business, but also for demonstrations!

However, on the basis that it's been taking over my life trying to get to the bottom of this, I created my own substitute command which works great on my Windows 7 PC and should be great for demonstrations.

Here it is:-

Command name "search

I added the following word list for the "searchtype" List Variable in the Name Editor

Calendar

Contacts

Documents

E-mail

Folders

Sub Main

HeardWord "search", "windows"

If ListVar1 = "E-mail" Then SendDragonKeys "Kind:=E-mail "

If ListVar1 = "Documents" Then SendDragonKeys "Kind:=Documents "

If ListVar1 = "Contacts" Then SendDragonKeys "Kind:=Contact "

If ListVar1 = "Folders" Then SendDragonKeys "Kind:=Folder "

If ListVar1 = "Calendar" Then SendDragonKeys "Kind:=Calendar "

TTSPlayString "what would you like to search for"

End Sub

After you get the voice prompt "what would you like to search for", you just say the search term.

The result - the search term search results come up instantly filtered by the above categories.

Peter

pmaddern2010-03-09 06:13:52

Peter,


I've discovered what I think might be the solution to your problem. Nuance's technical support was looking at one possible issue, and they were looking correctly. However, I have found something else that may be a source of these types of problems.

While I was working in Windows 7 64-bit, I found that all of the Voice Dictation Commands were not working in Microsoft Word 2007. I was getting the results box with a blue border which indicated that the commands were being recognized as commands, but they simply weren't executing. So, I went out and deleted the normal.dotm, which is usually the suspected culprit in such cases. However, on going back into Microsoft Word 2007, the problem persisted. I repeated the process and still the problem persisted. I uninstalled and reinstalled Microsoft Office 2007. Still, the problem persisted. I went round and round with this scenario until I finally gave myself a friendly slap upside the head and said to myself that this obviously wasn't the source of the problem.

Knowing what Nuance technical support knows, I went back into the services section in the Administrative Tools and did the same thing for all the services that control functions of DNS. Still, the problem persisted. I scratched my head for a couple of hours and remembered in a secure solution to command failure in DNS that I reported a number of years ago wherein commands were recognized but fail to execute. I went back into my notes and discovered that there were two factors involved: (1) one of the reasons that I recommended years ago when doing technical support for DNS was that it was possible for the mycmds.dat to become corrupted when users migrated previous version user profiles to a newer version, and (2) when this happens sometimes Natural Language Commands and custom commands can fail to execute. However, in most cases the problem occurred with regard to Natural Language Commands. Another cause of becoming corrupted was importing custom commands and allowing commands that already exist to be overwritten when prompted.

I know that I'm rewriting the Snows of Kilimanjaro here but I wanted to give you some background. So, try this:
1. Export your custom commands. If you're not sure whether which custom commands belong to DNS (out-of-the-box) and which are yours, don't worry about it. Just export all of your custom commands.
2. Delete the mycmds.dat and close your user profile (exit Dragon NaturallySpeaking).
3. Restart DNS and open your user. This will create a brand-new, pristine mycmds.dat that contains only the out-of-the-box DNS commands.
4. Import your custom commands. However, when you are prompted with the dialogue that says that a command already exists and do you want to overwrite it, select "No to All". This will then import only those custom commands that don't exist already. If you allow commands to be overwritten, you may end up in the same boat all over again. That is, this can corrupt your mycmds.dat file.
5. Make sure that you let the Command Browser finished completing the update. Then, close your user profile and reopen it. Retry executing the commands that you are having a problem and see if they work.
I'm not certain that this is the source of your problem, but it is possible (likely) because your problem is related to some of the same issues Re: my problem with Microsoft Word 2007. Let me know if this solves the problem. It would be good to know that this solution has multiple implications across numerous command execution failures under various conditions.

Chuck


Unfortunately, it didn’t solve the problem I’m afraid.


Still the same rogue behaviour. The command is definitely recognised as can be seen from the results box and the Windows 7 search screen flashes up for a fraction of a second and then closes.


But I really appreciate you going to the trouble of coming up with this potential soltion.


I’ve been looking at my event viewer (msconfig - Tools tab - Event Viewer) and I do see some error entries - like this one for example:-




I click on “Event Log Online Help” in the above screen and search on Error ID: 1000 but too many hits come up.


Is it a question of going through all these “error events” one by one? Trouble is I don’t know which event relates to my specific problem and which of the many solutions offered by Microsoft is the relevant fix!


Thanks


Peter


pmaddern2010-03-09 09:17:20

Peter,



First, when searching through the events log, you need only be concerned with the recent entries (i.e., March 1 through March 9). All the other entries are probably irrelevant.


Second, the errors that you are looking for are probably related to Windows Explorer since that is what the search window is. That is, it is simply a modified Windows Explorer window.


Lastly, are you certain that the window is closing or is it merely minimizing? If you look at the taskbar in Windows 7, by default there should be a folder likely to the right of the Internet Explorer ( e ). When you issue any of the search commands, click on that icon so that it launches Windows Explorer. If the search window is minimized, that is what will display. Therefore, my question is do you get a display of the standard Windows Explorer window, or does the search window come up?


To go any further, I need to know whether the search window is closing or merely minimizing. I tested this by simply minimizing that window and then clicking on that icon on the taskbar and what opened was the search window.


Otherwise, unless you find something in the events log related to Windows Explorer, I wouldn’t spend a whole lot of time on that because I don’t think that the problem is there, and even if it is, I would have to see it anyway to see whether or not that is the source of the problem. I was trying to search for issues related to minimizing the window spontaneously and how to set that properly. The only thing that I could find was to right-click on that icon and select un pin it from the taskbar.


Let me know if you discover anything relative to the above.
Chuck,
It's definitely not opening and then minimising.
It's like it tries to open but immediately gives up and closes. This behaviour takes place in a fraction of a second.
Peter

Peter,



Just out of curiosity, what happens when you open Windows Explorer and use the search bar.


For example, try entering a document name (path unnecessary), an e-mail name, and see what happens. Does Windows Explorer stay open and find what you are searching for. It may not find everything, but my concern is does the window close or does it remain open and show results? If it does remain open are the results valid? Are there any idiosyncrasies when searching this way?


The biggest question is, however, does Windows Explorer stay open when you do it this way. That’s basically what the DNS search functions do is use this window’s search bar.


I’ve been trying for weeks to duplicate your problem and can’t. Also, note that the Nuance technical support folks were looking in one place where you could have a problem. However, my reaction to the errors is that what they did to duplicate your problem is highly unlikely as a cause.

Chuck,

Yes, when I open Windows Explorer and Enter a document name or an e-mail name, Windows Explorer stays open and the search results are displayed with no idiosyncrasies. Searching this way executes perfectly. The window still remains open after displaying the search results.
In addition, the Advanced Scripting command I created (the one I mentioned in an earlier post in this thread) works perfectly.
Odd that a while back, when I reset my new laptop to factory condition, these built-in search commands work again perfectly for a few days and then stopped working. It's my perception, although I don't have facts to back this up, that some of the Windows automatic updates might have caused the problem. If they were, the trouble is I don't know which one(s) was the culprit(s)
Peter

Peter,


The only problem that I see with that assumption is that is that I have
a laptop with Windows 7 Home Premium 64-bit and a desktop with Windows 7 Ultimate 64-bit, and both of these have been fully updated as of this Tuesday. Neither has ever exhibited this problem and still currently don’t.

You may be right. That is, the updates may have something to do with it. However, I don’t think it’s the updates alone, and, because you can execute your command as well as search in the Windows Explorer search bar, it isn’t likely DNS.

Unfortunately, regardless of what it is, it’s going to be very difficult to track because there is no place that you can specifically point your finger and say “That’s it.” There are some places where you can set settings other than the defaults that might bring this problem about. However, tracking them is difficult. I have one more place to look and I will do so to see if one of these settings is at the root of the problem. Unfortunately, like the Nuance technical support, the possibility that one of these is the culprit seems unlikely, even if possible.

Thanks Chuck for the further comments.


Could this be a case of Dragon executing these commands too quickly for Windows 7? This proposition was put forward by Mr Orcutt on his forum. Probably not though as I have Windows 7 with 4 GB of RAM and even if I boost that with another 4 Gb RAM using Readyboost, these commands still don’t work.


If there was a way I could get at the scripts in these commands, I could copy them to new commands and “play around” with them e.g. try replacing SendDragonKeys with SendSystemKeys etc.


But as these are Natural Language commands, we can’t get at the scripts behind them can we?


Thanks


Peter

This problem has been solved unexpectedly whilst trying to solve a different problem!

I had a problem with my Windows 7 indexing service. I noticed that although it had indexed most everything, it was not indexing all of my Outlook 2007 e-mails. The indexing service was always routinely displaying the same number of unindexed e-mails.

I opened my indexing options and hit the index "rebuild" button. My problem then was that although the indexing options screen told me that indexing was taking place, it was stuck on zero items indexed even after several hours. So I tried to fix that.............

  1. I opened "indexing options" and unchecked all the selected folders being indexed
  2. I opened "Services", selected "Windows Search", clicked on the "Log On" tab and unselected "Allow service to interact with the desktop"
  3. I opened "Regedit", and found the line "HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindows Search"
    In the right pane, I right clicked on "SetupCompletedSuccessfully", clicked on "Modify" and changed the value from 1 to 0
  4. I rebooted the computer
  5. Indexing automatically selected the default search folders and started indexing - indexing seemed a hell of a lot faster than before and all my e-mails were indexed quite quickly.

Moreover, to my surprise and delight, Dragon's built in Windows desktop search commands now worked flawlessly.

I don't know specifically what did the trick? I'm not sure it was just re-building the index because I had already tried that bbefore without it resolving my Windows Desktop Search commands problem. I wonder if it was unselecting "Allow service to interact with the desktop" in the "Windows Search" entry under "Services"? I got several hits in my web search that this should not be selected and that it had caused some problems with indexing and searching.

So I was really happy until I ran into another problem which I managed to solve after a couple of hours.

Although my Dragon powered Windows Desktop Search was now "back on track", I found that I couldn't open any of the e-mail search results in the Windows search bar, despite being able to open Word and Excel documents in the search results.

More web searching revealed that other people had had this problem after installing Microsoft Office 2010. In my case, I had installed Microsoft OneNote 2010 from the Microsoft Office 2010 Professional Beta earlier this week. I uninstalled this and then everything was sweet. E-mail search results in the search pane now had their contents previewed in the search results for the first time and emails immediately on clicking on selected items.

I thought I would share this in case anybody else finds they have issues with Windows Desktop Search commands not working any more with Dragon NaturallySpeaking 10.1.

I find troubleshooting compuer issues like this can become a full - time career if you're not careful!

Peter
Speech Empowered Computing

Peter,



Thank you for sharing this information. Since I had not had any problems with the built-in DNS search commands, it didn’t cross my mind to check the indexing, which in my case wouldn’t have resulted in a whole lot of understanding as conveyed by your post.


However, I also didn’t consider that anyone who is having this problem might possibly have installed Microsoft Office 2010 Beta. It’s very helpful to have in my notes your experience with Microsoft Office OneNote 2010. On the other hand, I have warned everyone on most of the forums not to install Microsoft Office 2010 Beta, if only for the reason that it is absolutely incompatible with DNS. In addition, it can be a royal pain in the butt to get completely uninstalled and interferes with Microsoft Office 2003/2007 anyway.

Nevertheless, your careful documentation is much appreciated.

The only thing that I would add for the benefit of those who are having this particular problem is that you get to these options and settings via the Windows Control Panel | Indexing Options. The only reason I bring this up is because even though it’s right under your nose once you open the Windows Control Panel, it’s not obvious from the desktop exactly where to go.

Also, I would stress to those users who are not comfortable with or familiar with the Windows system registry to be careful making modifications to such. If anyone wants to use peters registry hack, be sure that you make a full backup of your Windows system registry first. It’s very easy to get in trouble playing around with the Windows registry, and very hard to get out of it. Chucker2010-04-10 23:14:04