Changing color of selected text

I used to be able to give the command when I selected text “make that [whatever color].” Doesn’t work now. The Dragon command doesn’t work either. For example, I select a word and want to change it to read. I give the Dragon command “set the color to red in the selection.”

Incredibly, when I go up to the I guess ribbon on the taskbar called “font color” after making the selection and choosing red, again it stays black.

At least my reading of VoiceComputer’s word commands is if I select the word and want to make it red, the command is “make it red.” That doesn’t work either.

Any thoughts would be greatly appreciated.

Jim

Jim,

Both of the commands that you’re trying to execute are Dragon commands, not VoiceComputer commands. They may be listed in the Microsoft Word commands list, but they are Dragon commands. Easy to test this out by simply loading Dragon by itself and issuing the same commands.

If you are unable to manually changed color from the Ribbon bar “font color”, then the commands that you’re trying to issue won’t work either (obviously). Nevertheless, something is preventing you from editing your text. This can happen if a document is in “Read-only” mode (protected mode) or something is set to prevent you from editing the document.

Couple of quick questions:

Is this a new document or one that you created earlier? Also, this can sometimes happen if you open a file that you downloaded.

Do you have more than one document open?

What version of Microsoft Word (Microsoft Office) are you using?

Have you tried other documents?

If you close Microsoft Word (being sure that you close all documents open in MS Word) and reopen Microsoft Word followed by creating a new document and dictating into it and then issuing the commands, do they still not work?

Have you tried closing Microsoft Word, including all documents, shutting down VoiceComputer and Dragon and restarting (Restart Speech) and then opening Microsoft Word, do you still have the same problem?

One thing that’s important to keep in mind is that you can shut down VoiceComputer and Dragon and restart (per above) without closing Microsoft Outlook, but you have to close Microsoft Word completely and reopen it after Dragon and VoiceComputer are reloaded. Otherwise, the NatSpeak Word AddIn is not initialize and you have no Full Text Control (Select-and Say), with the consequent result that none of the font color commands will work. Microsoft Word always has to be loaded after Dragon/VoiceComputer. Microsoft Outlook does not.Chucker2013-08-23 02:44:32

Chucker:

thanks so much for getting back to me. The problem occurs with a new document and when it is the only document. I’m using Microsoft Word 2010. Lately, I have been closing down my computer completely at night to make sure the memory clears, I think that’s what it means. Nothing works when I start my computer in the morning, double-click VoiceComputer so it and Dragon opens and then create a new document in Word.

Does this help?

Much appreciated.

Jim

Jim,

The only thing I can suggest at this point, simply because I’m not having a problem with it Windows 8 using Microsoft Office 2010 (Microsoft Word), is to try running a repair of Microsoft Office and see if that fixes the problem. The problem may be with Microsoft Office 2010 because, as you say, you can’t even change the font color manually.

Thanks, Chucker:

ran the repair. No go. Should I uninstall Microsoft office and reinstall?

Much appreciated,

Jim

Jim,

You can try uninstalling and reinstalling Microsoft Office, but there’s a 50-50 chance that that will fix the problem. The problem is in Microsoft Office, not VoiceComputer or Dragon. If you can’t manually change the font color, then something is blocking your ability to edit a document. If manual font color changing, doesn’t work then no command on the face of this earth, regardless of its source, is going to execute either.

What we have to do is to get to the bottom of why you can’t manually edit the font color. Once we get to the bottom of that, then the commands will work.

Chucker:

uninstalled Microsoft Office Professional 2010 and reinstalled it. Interestingly, the font color came up as read in the ribbon. The dictation still came up black. Still couldn’t change the color. I even purchased KB 2012 (I am embarrassed that I had not upgraded until now) and tried its commands. Still nothing.

Manual changing didn’t work either.

Very interesting.

Thanks so much,

JimTrionalaw2013-08-26 07:52:34

How about this, Chucker?

I decided to uninstall Microsoft Office Professional Plus 2010 and install Microsoft Office Standard 2007. I dictated a sentence in Word. I selected two words. I gave the command “make it red.” And guess what? It worked.

This ought to make things really interesting, don’t you think?

I had to revert to my 2010 version because my email is set up for it rather than the 2007 version. It is through our network. Of course, I am back to the original problem. I did note that when I opened word again, it came up with red as the font color. I click the little icon in the corner to go to the default settings. I changed the font color to automatic which is black, and but it remained on red. I don’t know if this helps or not.

Thanks,

JimTrionalaw2013-08-27 08:55:58

Jim,

As a last thought, the problem might be with your normal.dotm in Microsoft Word.

Go to the following location:

C:UsersAppDataRoamingMicrosoftTemplatesNormal.dotm

Rename the Normal.dotm to Normal_old.dotm

Then open Microsoft Word. Microsoft Word will use the default settings or the Normal.dotm. That might possibly be where the problem was. Otherwise, the only thing I can think of is that you’re running in protected mode or compatibility mode, which trying to figure out using Microsoft Word Help to figure out how to properly set these up is like pulling teeth.

Let me know if the above works.

PS, after going back to Microsoft Office 2010, are you able to manually select text and change the font color? Reason I ask is because if you can now do it manually, then the commands to work.Chucker2013-08-27 14:17:41

Thanks Chucker,

I found a normal and a normal old. I deleted the latter and changed the normal to Normal_old.dotm

Still no control over font color. I can’t change color with choosing a selection. I other words my font colors are the same as the Model T: all colors as long as it is black. And in the art world black is not even considered a color.

I will run repair and see if it helps since I reinstalled the rogram.

Weird.

Jim

Still nothing after running repair.Trionalaw2013-08-27 15:39:28

Now things are really interesting. I followed this advice:

I uninstalled office 2010. I then deleted the following files in black:

C:Program FilesMicrosoft Office

C:Program FilesCommon FilesMicrosoft SharedOffice14

C:ProgramDataMicrosoftOffice

%AppData%MicrosoftOffice

Then deleted the following registry keys:

HKEY_LOCAL_MACHINESOFTWAREMicrosoftOffice
HKEY_CURRENT_USERSoftwareMicrosoftOffice

I could not find %AppData%MicrosoftOffice I could not delete HKEY_LOCAL_MACHINESOFTWAREMicrosoftOffice.

I then reinstalled office 2010.

With WordPad I could change colors. However, I have to do it manually. No commands work. However, I rebooted and now the commands work in WordPad.

Now the kicker, I can’t dictate into Microsoft Word, even after I rebooted! It is times like these that I wish I had been practicing law in the 1890s. I’m so frustrated I am thinking about watching “Honey Boo-boo” just to torture myself and hope the voice recognition god’s will allow me to dictate into word.

Any ideas?

Thanks so much,

Jim

Trionalaw2013-08-28 08:35:52

Jim,

First, is your version of Office 2010 32-bit or 64-bit?

Second, if you go into the Options dialog | Add-ins in Microsoft Word, is the NatSpeak Word AddIn listed under the Active Application Add-ins? If not, then you may be prevented from dictating into Microsoft Word.

If that is the case, then click on the “Go” button with COM Add-ins listed in the drop-down list to the right of Manage: and put a checkmark in the NatSpeak Word AddIn box, making sure that after you close that you go back and check it again to make sure that it has been moved to the Active Application Add-ins. Otherwise, it may be disabled, in which case you have to drop the list to the right of Manage: and select Disabled Items and reselect it, followed by making sure that it ends up being added to the Active Application Add-ins as described above.

PS, I just noted that your post on the KnowBrainer forum that included the screen captures show that the NatSpeak Word AddIn is completely missing (i.e., it’s neither in the Active Application Add-ins, nor the Inactive Application Add-ins, nor the Disabled Items. In other words, it’s missing completely.

The first thing to keep in mind is that either your loading Microsoft Word before Dragon, or Microsoft Word 2010 is simply not loading it.

To add the NatSpeak Word AddIn, do the following:

  1. Determine whether you’re using the 32-bit or 64-bit version of Microsoft Word 2010. If you’re using the 32-bit version then the file is dgnword.dll. If you using the 64-bit version, then the NatSpeak Word AddIn is dgnword_x64.dll.

  2. For the 32-bit version of Microsoft Word 2010, dgnword.dll is located in the following location:

C:Program Files (x86)NuanceNaturallySpeaking12Programdgnword.dll

if you’re using the 64-bit version, then dgnword_x64.dll is located in the following location:

C:Program Files (x86)NuanceNaturallySpeaking12Programx64dgnword_x64.dll

  1. In the Microsoft Word 2010 Options | Add-ins, click on the “Go” button with the options for COM add-ins selected in the drop-down list to the right of Manage:

Click on the Add button and go to the appropriate location as noted in #2 above and select the appropriate NatSpeak Word AddIn. Make sure that there is a checkmark in the checkbox after doing so and then click or say “OK”. Go back into the Microsoft Word | Options | Add-ins and make sure that the NatSpeak word add the is listed under the Active Application Add-ins. If not, take the appropriate action to make sure that it is added to the Active Application Add-ins.

Unless you can get Microsoft Word 2010 to load the NatSpeak Word AddIn into the Active Application Add-ins, then Microsoft Word won’t function and you will continue to be unable to dictate into Microsoft Word.Chucker2013-08-29 08:18:01

Chucker:

I decided to run a repair of Dragon. The green checkmark is now in the DragonBar and I can dictate into Word 2010. However, the font color problem persists.

Truly troubling.

Thanks,

Jim

PS: probably unrelated, but now I can’t get to my document saved on my network drive. Can’t do so with WordPad either.

Jim,

Can you change font sizes and styles manually or by voice command (i.e., saying set font times new Roman 12 points)? Can you do it by keyboard?

I tried everything I can to get font color and font sizes and the other Natural Language Commands in Microsoft Word 2010 to fail and I couldn’t. Regardless, if you can’t do it manually by keyboard, then you won’t be able to do it by voice command.

Your problem has me buffaloed because I never experienced that ever with DNS and/or VoiceComputer.

Chucker:

the command “set font Times new Roman 12 points” was always recognized as “set font Times new Roman 12 point.” How would I fix that?

However, when I gave the command “set font Times new Roman” Word recognized it.

So it’s all about the color I guess.

Thanks so much and enjoy your holiday weekend.

Jim

Chucker,

I hope you saw that this problem was solved from the KnowBrainer forum. I changed my background screen to the standard Windows 7 and that fixed it!

Thanks for all your help as usual.

Jim

Jim,

Just out of curiosity, what did you specifically change (step-by-step). I just want to see what it is that you did specifically and what the original settings were that were causing the problem.

Chucker:
I thought I would post this as well. Here is what I received on the KnowBrainer forum which magically fix the problem . I just change to the standard Windows theme.

Sorry for not getting back to you sooner. My trial schedule was crushing for three weeks.

Jim

Try changing your Windows theme to see what happens regarding the Microsoft Word font colour problem. Right click on the desktop and then choose Personalise and then choose one of the Windows default themes. If for example you are using a high contrast theme and this can cause the problems you are having. After changing the theme log out and then log back in again.

If that makes no difference then chances are your Windows user settings are messed up. Can you create a temporary administration user, load Microsoft Word 2010 with that user and see if it works. I am hoping you have installed office to be available for all users and NaturallySpeaking. If it works with the new user let us know and we can eliminate possibilities with your existing Windows user.

Can you colour things by voice with Excel? You can use the same NaturallySpeaking commands to do this e.g. “make it red”, “color it red”