Certain VoiceComputer commands don't work for me

Hello. Ever since I installed VC for the first time, I have not been able to use the “show website”, “place mouse” commands under the configure VoiceComputer menu, nor have I been able to use the “save to/open from” commands. Can you please tell me how I can fix this? I would really like to be able to use these commands. Thanks!

Are you able to open the main menu when you say, “show main menu”?
RonK2013-08-19 16:25:33

You need to configure VoiceComputer to enable the commands you want (and disable those you don’t need).


Say, "Configure VoiceComputer"

And then “17 Open” where 17 is the number of Enable | Disable VoiceComputer commands.

Say the name of the command to enable or disable the command set you want. (Depending on your Dragon configuration, you may have to use the prefix "Click."

You’ll want to enable “Web Search Commands” and maybe "Mouse on 2nd/3rd Monitor."

Bug report: The option to enable “Mouse on 2nd/3rd Monitor” was accidentally left off a few versions of VoiceComputer. If your configuration doesn’t display this option, open the settings.ini file located in the DocumentsVoiceComputer directory and change the MOUSE2 entry to MOUSE2=1. Restart VoiceComputer to activate these commands.


@garysolo I am indeed able to and have it appear.

Ron: I ticked the appropriate boxes and am still unable to launch any websites via the “show website” command. What else can I do to get this to work?

You restarted VoiceComputer, correct?

Does Dragon recognize the commands? - Show New York Times Site, Show Yahoo Site - (The results box has a blue border when a command is recognized.)

If Not:
Does the “Open Gmail” command work?
Does the system recognize “Show Deletion Commands”?

Try again. “Configure VoiceComputer”, select “Enable | Disable…”
Make some changes or just select “OK” and then restart VoiceComputer.
As the programs are being shut down, does a configuring VoiceComputer window briefly open?

ronAdmin2013-08-19 20:08:57

Ron:

I did everything you mentioned, and the only thing that works is “show deletion commands”. The Yahoo command worked yesterday, but it’s not working today. No, I don’t see any configuration window when VC shuts down.

Update: After restarting Voice Computer, I was able to execute the open gmail command, and did see a little box briefly before being taken to Gmail.

Reed,

Keep in mind that any time that you change the settings in the “Enable | Disable VoiceComputer commands”, VoiceComputer has to be restarted in ordered for those changes to take effect. In addition, if you just want to go up to that dialog and look at what the settings are but don’t want to make any changes, don’t click OK, click Cancel. Otherwise, you will end up in the situation of being forced to restart VoiceComputer.

Chuck,

Okay, I will keep that in mind. What can I do to get these features to work? Thanks!

Reed,

Let’s go back to square one. What are the exact commands that you are saying verbatim?

In order to determine why these commands are not working for you, we need to know exactly what you’re saying verbatim when you issue the. It’s possible that you’re not saying the right command.

Chuck,

I am dictating: “Show Yahoo Site”, “Show New York Times Site” and “Show Academy Site” (a custom site I added).Dragon consistently understands entirely different utterances.

Please go to your

DocumentsVoiceComputerCommandsCustom

directory.

Do you see a web.xml file
and a voiceshortcuts1.xml file.

If not, say, “Configure VoiceComputer”, select “Enable | Disable …”
and confirm that “Web Search Commands” and “Voice Shortcut Commands” are checked (Need the Voice Shortcut Commands in order to create your own commands.)

If they’re not checked. Check them, restart VoiceComputer and see if the two files are in the DocumentsVoiceComputerCommandsCustom directory. If the command lists are present, try the commands. If not, let us know.

RonK2013-08-20 12:57:31

Ron,

Those two boxes were already checked under number 17, but I unchecked and rechecked them and also restarted Voice Computer. However, the files are still not present in the Commands folder…

Go to your
C:Program Files (x86)VoiceTeachVoiceComputerhelpVC_FilesCustom_files

directory and copy
web.xml file
and voiceshortcuts1.xml

to your
DocumentsVoiceComputerCommandsCustom
directory.

Restart Speech and the commands should work.

I’ll send you a test file in a couple of days so we can figure out why these files aren’t being copied on your system.

Thanks Ron, that worked. I was able to open both the Yahoo site and my custom site. When I tried saving a file to a bookmarked folder, my computer went crazy and started opening the WinRAR dialog. I must be doing that one wrong… Will I have to do all this copying and pasting of xml files by hand until this issue solved in order to add custom commands?

Reed,

It would also be helpful if you were to say “show VoiceComputer version” and tell us what the version number that you have installed is.

Chuck,

I believe I have the latest version: 12.5.1.2 is what I get when I dictate the command you indicated to me.

Reed,

That is the most current version. Unfortunately, I can’t duplicate your problem because it works fine on mine. That is, with those commands enabled the “configure VoiceComputer” #17, they are enabled on all three of my systems.

I’ll have to leave this one to Ron to figure out since I can’t duplicate the problem so I can’t analyze it.

Chuck and Ron,

In a nutshell, problem solved. Last night, after a bout of slow computer activity, I had to restart my computer at which point it prompted me to run a check disk. After that, all the Voice Computer commands started working perfectly! I was even able to run a new custom “show website command” without doing anything special. I’m now going to test the “save to” command to see if and how it works. Thanks for your help!

Update: The “save to” command works perfectly.