Anyway to get Dragon to better cooperate in Chrome browser?

I use Dragon 15.3 along with its own extension + the InTags extension in Chrome. I usually turn off InTags. Throughout the day, while dictating something into Chrome, for example, text in a form field, or a rich text editor (making a post in WordPress, for example) Dragon simply stops converting my voice to text. There are two solutions:

  • Do something which forces Chrome to give me a “You have unsaved data, are you sure you want to exit? [Close/Cancel]” and when I click “cancel”, dictation works again. For example, in some programs, if your content hasn’t been saved as a draft, it will trigger this when you try to close Chrome.
  • Close Chrome and restart.

I probably do this at least 10 times a day. Is there any way to force Chrome + Dragon to play nicely together?

The 2021 release of VoiceComputer includes a new dictation box (“Dictate Now”). You can use this instead of dictating into Chrome.
The Chrome extension is no longer required with VC2021 but it’s still an option.