Adjust timing of VoiceComputer at startup/restart?


I made this a new post because it is a new twist on this post:

http://old.voicecomputer.com/forum/forum_posts.asp?TID=657&title=when-voicecomputer-starts-dragon-can-it-load-a-sp

I have since discovered two situations where using VoiceComputer as my startup option hardly ever works--initial startup and restart. Dragon never opens, and VC exits.

Here is what I see: Dragon opens the profile selection screen. The script opens the VC pdf guide. The profile selection screen loses focus. The script therefore never clicks the Open button. This suspends Dragon's opening, and VC exits.

Here, I hope, is the relevant part of VoiceComputer log.txt:

INFO :

Starting up VoiceComputer on Microsoft Windows NT 6.2.9200.0 (timestamp: 250 ) 2017-10-06 11:29:56,361
INFO : Started logger. (timestamp: 328 ) 2017-10-06 11:29:56,439
INFO : reading ini file C:ProgramDataVoiceTeachVoiceComputersettings.ini (timestamp: 328 ) 2017-10-06 11:29:56,439
INFO : using Dragon's Speech Engine, and the Help database for DNS (timestamp: 29253 ) 2017-10-06 11:30:25,364
INFO : A user does not appear to be loaded in Dragon. Will wait 7 seconds and look again. (timestamp: 32113 ) 2017-10-06 11:30:28,224
INFO : Still no user loaded in Dragon. Will try to open _MYDOCSVoiceComputerDocumentationVPSetup.chm before exiting. (timestamp: 39130 ) 2017-10-06 11:30:35,242
INFO : Exiting Application (timestamp: 41459 ) 2017-10-06 11:30:37,570

On the other hand, if I log off and log back in, the option usually works as advertised.

Can I get rid of the pdf Guide? This seems to cause the bottleneck.
doicet2017-10-06 07:20:10

Although I can’t duplicate your problem, your post makes it clear what’s going on so I can’t fix it.



The PDF file should open only during the first three startups of a new version of VoiceComputer.

Does it continue to open on your computer?

<div><br></div><div>Yes.</div>

Daniel,

It should function as Ron points out. That is, it should never continue to open after the third time.

In the settings.ini for VoiceComputer, you have the following entries under [GENERAL]

[GENERAL]
MIC_RESTART=24:00
STARTUPSCREEN=1
USES=3
DRAGON11BUG=false
DRAGONVER=15
FIRSTUSE=0
CONTROLCENTERTIMER=30
ENGINETYPE=dragon
DRAGON12BUG=true

The settings.ini file is located as follows:

C:ProgramDataVoiceTeachVoiceComputersettings.ini

Make the following changes:

[GENERAL]
MIC_RESTART=24:00
STARTUPSCREEN=0
USES=3
DRAGON11BUG=false
DRAGONVER=15
FIRSTUSE=0
CONTROLCENTERTIMER=30
ENGINETYPE=dragon
DRAGON12BUG=true

Note that FIRSTUSE should always equal "0", USES will progress from 1 to 2 and then finally 3 as is the case in your listing in your post. Once USES=3, the screen will no longer display.

STARTUPSCREEN=1 is the setting that starts executing the startup screen, or First Use Screen. Setting this to "0" as shown above should prevent it from ever happening or, at least, never reoccurring after the first instance. Unfortunately, because the way that the install and opening up VoiceComputer for the first time works, it's not possible to edit this section when you first start up after installing a new version. Nevertheless, by using the above suggestions you can prevent it from happening on restart after configuring VoiceComputer. You still have to edit the settings.ini file after configuring VoiceComputer and before you restart VoiceComputer.

When making such changes, you should always restart VoiceComputer and Dragon after editing the settings.ini file.

Chucker2017-10-10 08:12:36