The Voice Computer Forum visit our website at www.voicecomputer.com

Forum Home Forum Home > Speech Recognition > VoiceComputer
  New Posts New Posts RSS Feed - Activate microphone not working
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Activate microphone not working

 Post Reply Post Reply Page  <12
Author
Message
Thomas Reid View Drop Down
Newbie
Newbie


Joined: 27 Mar 2018
Location: Pennsylvania
Points: 36
Post Options Post Options   Thanks (0) Thanks(0)   Quote Thomas Reid Quote  Post ReplyReply Direct Link To This Post Posted: 04 May 2019 at 8:51am
Once I set my secondary to a much higher level than I had before (as mentioned, to the number suggested during the optimize process), my false positives have gone away. My success using the double command process works extremely well now.  It now works exactly as expected.





Tom
Back to Top
RonK View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 07 Jan 2010
Points: 974
Post Options Post Options   Thanks (0) Thanks(0)   Quote RonK Quote  Post ReplyReply Direct Link To This Post Posted: 04 May 2019 at 10:03am
Great!
My documentation needs to be improved because some get it and some don't
If you have time, please write a short explanation of how to configure the mic feature or how it works.
Thanks!



Ron

VoiceComputer Developer
Back to Top
Thomas Reid View Drop Down
Newbie
Newbie


Joined: 27 Mar 2018
Location: Pennsylvania
Points: 36
Post Options Post Options   Thanks (0) Thanks(0)   Quote Thomas Reid Quote  Post ReplyReply Direct Link To This Post Posted: 04 May 2019 at 4:04pm

To optimize the Voicecomputer microphone (manually)

Note: there are two confidence levels, primary and secondary.  Either number will activate the program
   to start looking for the command ("activate microphone" or "activate voice computer").
   If you set either number too low, you will encounter several "false positives" (microphone
   turning off or on, or the screen to request a voice computer restart" at undesired times).

1.  Start the "VC Microphone" application, or make sure it is running.
2.  Issue the voice command "activate microphone" a few times

Optional steps
a.  Open the file C:/programData/voiceteach/microphone/VC_microphonelog.txt
b.  Don't worry that there are too many "heard: 'activate microphone" entries
c.  Note the confidence levels in general.  Note particularly where you see "not a secondary match"
d.  This will give you a good idea of where to set the secondary match confidence level


4.  With the Dragon Mic on, issue the voice command "optimize microphone"
5.  This will open up a second log file that has confidence levels when the activate command was 
     successfully heard.
6.  I recommend setting the primary confidence level quite high, say around 98%
7.  Set the secondary confidence level at about the numbers that you observed in either the 
     successful heard log (step 5), or the higher numbers that you notice in the 
     VC_microphoneLog file in the optional steps above. Start a little high, you would repeat 
     this process from step 4 through step 7 by slightly lowering the secondary number until 
     you consistently get the results you're looking for.
Tom
Back to Top
RonK View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 07 Jan 2010
Points: 974
Post Options Post Options   Thanks (0) Thanks(0)   Quote RonK Quote  Post ReplyReply Direct Link To This Post Posted: 05 May 2019 at 6:40am
Great explanation!!!  I'm glad that I asked.
This should be a great help to our users!

Thanks!
Ron

VoiceComputer Developer
Back to Top
Thomas Reid View Drop Down
Newbie
Newbie


Joined: 27 Mar 2018
Location: Pennsylvania
Points: 36
Post Options Post Options   Thanks (0) Thanks(0)   Quote Thomas Reid Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2019 at 12:12pm
here we go again. I was not having any problems after getting the right numbers in the configuration file. The current logs are telling me that the "activate microphone" command is being heard quite consistently at around 94.5%. I have set my values near that number, and well below that number. However, after installing the 2020 version, I'm having problems with just this one command as far as action. Like I said, the program is recognizing the command just fine, but nothing is happening-if the microphone is off in Dragon, it will not restart when I give this command. I was having no problem just before the installation.

Can you give me any advice?
Tom
Back to Top
RonK View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 07 Jan 2010
Points: 974
Post Options Post Options   Thanks (0) Thanks(0)   Quote RonK Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2019 at 10:11am
Please email me the VC_MicrophoneLog.txt in the C:\ProgramData\VoiceTeach\Microphone directory

The "activate microphone" will not activate the Dragon mic if the "VoiceComputer Control Center" is active" (Will soon release an update that will fix this.)

Check that you have disabled all but one of your microphones.
Right click on the speaker icon on the system tray > Open Sound Settings > Sound Control Panel > Recording 


Check the system volume (which the VC Mic uses). 
Right click on the speaker icon on the system tray > Open Sound Settings > Sound Control Panel > Recording > Microphone > Levels

Set it to 80%.  (Various utilities will change the volume. The update I'm working on will set the volume to 80% and keep it there.)


Edited by RonK - 07 Sep 2019 at 10:12am
Ron

VoiceComputer Developer
Back to Top
Thomas Reid View Drop Down
Newbie
Newbie


Joined: 27 Mar 2018
Location: Pennsylvania
Points: 36
Post Options Post Options   Thanks (0) Thanks(0)   Quote Thomas Reid Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2019 at 12:24pm
looks like the culprit was that my Dragon hotkey for turning the microphone on and off was empty.

it is working fine now that I have reset the Dragon options back to default.

What threw me off initially was that when I went into the configuration for VoiceComputer, option seven, that process was telling me that my confidence levels were 94% plus.  However, when looking at the log file that you suggested here, the confidence values are much lower. I have now adjusted my levels to reflect what is in the above log file.

I just rediscovered why I changed my default hotkey values in Dragon. When I give the command "press enter", dictated twice, it turns off my microphone. I don't know if that's a dragon thing, or a  VoiceComputer thing, or something else on my computer.

another issue that is quite confusing, microphone command 1 is "activate microphone", so we give settings for that. The impression given on the screen instructions suggest that the settings for commands 3 can be a little lower. However, one of the recognized strings for commands three is "activate microphone". These two commands are fighting each other it would seem.



 
 

Tom
Back to Top
RonK View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 07 Jan 2010
Points: 974
Post Options Post Options   Thanks (0) Thanks(0)   Quote RonK Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2019 at 6:21pm
I just rediscovered why I changed my default hotkey values in Dragon. When I give the 
> command "press enter", dictated twice, it turns off my microphone.

Yes, you and/or someone else reported this some time back.

Does the enter key and numkey+ share the same key on your computer? 

There's a 'Enter two' (enter <1-20>) command in VoiceComputer, not VoiceComputer lite.

Could you use this instead of   "press enter", dictated twice?

Or, you can try another hotkey for the Dragon mic. (You have to restart the VC Mic) 

> However, one of the recognized strings for commands three is "activate microphone"

That wouldn't be the case in the next update...
Ron

VoiceComputer Developer
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.01
Copyright ©2001-2014 Web Wiz Ltd.

This page was generated in 0.219 seconds.